# CVE-2018-16738: Auth bypass in n/a

> Attackers can bypass authentication in tinc VPN software due to a broken protocol, allowing unauthorized access to the network.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2018-16738, DEBIAN-CVE-2018-16738, GHSA-c478-67p7-rg2p, UBUNTU-CVE-2018-16738

## What is CVE-2018-16738?

CVE-2018-16738 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 10 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

tinc 1.0.30 through 1.0.34 has a broken authentication protocol, although there is a partial mitigation. This is fixed in 1.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-16738?

It affects 3 products.


Products: Debian Debian Linux, Starwindsoftware Starwind Virtual San, Tinc-Vpn Tinc.

## How do I fix CVE-2018-16738?

Upgrade to a fixed version.

## Is CVE-2018-16738 being exploited?

There is no known exploitation of CVE-2018-16738 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16738 and fix it if it is affected.

What it is: CVE-2018-16738 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 10 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16738 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16738/ (Markdown: https://insights.sbomify.com/CVE-2018-16738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16738
- OSV: https://osv.dev/vulnerability/CVE-2018-16738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16738/
Summaries are generated and may contain mistakes; the official description above is the record.
