# CVE-2018-16848: OpenStack Mistral DoS

> Attackers can cause denial of service in OpenStack Mistral by submitting crafted YAML workflow definitions with nested anchors.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2020
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-16848, GHSA-443j-6p7g-6v4w, PYSEC-2020-240, UBUNTU-CVE-2018-16848

## What is CVE-2018-16848?

CVE-2018-16848 is a medium-severity denial of service vulnerability in openstack-mistral, published on 15 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Denial of Service (DoS) condition is possible in OpenStack Mistral in versions up to and including 7.0.3. Submitting a specially crafted workflow definition YAML file containing nested anchors can lead to resource exhaustion culminating in a denial of service.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-16848?

3 open source packages ship an affected version, including mistral. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mistral` | PyPI | All versions | 10.0.0 |
| `mistral` | PyPI | All versions | 10.0.0 |
| `mistral` | PyPI | All versions | 7.0.4 |

Products: Redhat Openstack-Mistral.

## How do I fix CVE-2018-16848?

Upgrade mistral to a fixed version for your release line: 10.0.0 or 7.0.4.

## Is CVE-2018-16848 being exploited?

There is no known exploitation of CVE-2018-16848 in the wild and no public exploit code.

## Other vulnerabilities in openstack-mistral

- [CVE-2019-3866](https://insights.sbomify.com/CVE-2019-3866/): Information disclosure in openstack-mistral (medium 5.9)
- [CVE-2018-16849](https://insights.sbomify.com/CVE-2018-16849/): openstack-mistral Discloses the presence of arbitrary files within the filesystem (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16848 and fix it if it is affected.

What it is: CVE-2018-16848 is a medium-severity denial of service vulnerability in openstack-mistral, published on 15 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16848 in the wild and no public exploit code.

Affected packages and fixed versions:
- mistral (PyPI): affected all versions; fixed in 10.0.0
- mistral (PyPI): affected all versions; fixed in 10.0.0
- mistral (PyPI): affected all versions; fixed in 7.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16848/ (Markdown: https://insights.sbomify.com/CVE-2018-16848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16848
- OSV: https://osv.dev/vulnerability/CVE-2018-16848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16848/
Summaries are generated and may contain mistakes; the official description above is the record.
