CVE-2018-16854 Moodle Login CSRF vulnerability in login form
Attackers can force logged-in users to perform actions without consent due to missing CSRF tokens on the login form.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-16854?
CVE-2018-16854 is a medium-severity vulnerability in Moodle Moodle, published on 26 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Weakness: CWE-352
Which versions are affected by CVE-2018-16854?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.15 |
moodle/moodle Packagist | From 3.1 | 3.1.15 |
moodle/moodle Packagist | From 3.3 | 3.3.9 |
moodle/moodle Packagist | From 3.3 | 3.3.9 |
moodle/moodle Packagist | From 3.4 | 3.4.6 |
moodle/moodle Packagist | From 3.4 | 3.4.6 |
2 more packages
moodle/moodle Packagist | From 3.5 | 3.5.3 |
moodle/moodle Packagist | From 3.5 | 3.5.3 |
Products include Moodle Moodle.
How do I fix CVE-2018-16854?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.15, 3.3.9, 3.4.6 or 3.5.3.
Is CVE-2018-16854 being exploited?
There is no known exploitation of CVE-2018-16854 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-xj5f-qv37-r9jc, UBUNTU-CVE-2018-16854.