CVE-2018-16859 Ansible Logs Passwords If PowerShell ScriptBlock is Enabled
Local administrators can view plaintext become passwords in Windows EventLogs when specific logging features are enabled in Ansible.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-16859?
CVE-2018-16859 is a medium-severity vulnerability in Red Hat ansible, published on 29 Nov 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.
Weakness: CWE-532
Which versions are affected by CVE-2018-16859?
7 open source packages ship an affected version, including ansible. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | All versions | 2.5.12 |
ansible PyPI | All versions | 2.5.12 |
ansible PyPI | From 2.6.0a1 | 2.6.9 |
ansible PyPI | From 2.6.0a1 | 2.6.9 |
ansible PyPI | From 2.7.0 | 2.7.4, 2.8.1, 2.5.13, 2.6.10 |
ansible PyPI | From 2.7.0a1 | 2.7.3 |
1 more packages
ansible PyPI | From 2.7.0a1 | 2.7.3 |
Linux distribution packages (5)
ansible Red Hat:ansible_engine:2.5::el7 | All versions | 0:2.5.13-1.el7ae |
ansible-doc Red Hat:ansible_engine:2.5::el7 | All versions | 0:2.5.13-1.el7ae |
ansible Red Hat:ansible_engine:2.6::el7 | All versions | 0:2.6.10-1.el7ae |
ansible Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.4-1.el7ae |
ansible Red Hat:ansible_engine:2::el7 | All versions | 0:2.7.4-1.el7ae |
Products include Redhat Ansible Engine.
How do I fix CVE-2018-16859?
Upgrade ansible to a fixed version for your release line: 2.5.12, 2.6.9, 2.7.4 or 2.8.1.
Is CVE-2018-16859 being exploited?
There is no known exploitation of CVE-2018-16859 in the wild and no public exploit code.
Other vulnerabilities in Red Hat ansible
Sources
Also known as ALPINE-CVE-2018-16859, GHSA-v735-2pp6-h86r, PYSEC-2018-60, RHSA-2018:3770, RHSA-2018:3771, RHSA-2018:3772 and 1 more.