# CVE-2018-16873: Command injection in golang

> Attackers can execute arbitrary commands on the developer's machine by tricking the Go toolchain into treating a malicious directory as a Git repository.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-q6pp-3q54-qw37, GO-2022-0189, UBUNTU-CVE-2018-16873

## What is CVE-2018-16873?

CVE-2018-16873 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Go before 1.10.6 and 1.11.x before 1.11.3, the "go get" command is vulnerable to remote code execution when executed with the -u flag and the import path of a malicious Go package, or a package that imports it directly or indirectly. Specifically, it is only vulnerable in GOPATH mode, but not in module mode (the distinction is documented at https://golang.org/cmd/go/#hdr-Module_aware_go_get). Using custom domains, it's possible to arrange things so that a Git repository is cloned to a folder named ".git" by using a vanity import path that ends with "/.git". If the Git repository root contains a "HEAD" file, a "config" file, an "objects" directory, a "refs" directory, with some work to ensure the proper ordering of operations, "go get -u" can be tricked into considering the parent directory as a repository root, and running Git commands on it. That will use the "config" file in the original Git repository root for its configuration, and if that config file contains malicious commands, they will execute on the system running "go get -u".

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-16873?

1 open source package ship an affected version, including toolchain. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `toolchain` | Go | All versions | 1.10.6, 1.11.3 |

Products: Debian Debian Linux, Golang Go, Opensuse Backports Sle, Opensuse Leap, Suse Linux Enterprise Server.

## How do I fix CVE-2018-16873?

Upgrade toolchain to a fixed version for your release line: 1.10.6 or 1.11.3.

## Is CVE-2018-16873 being exploited?

There is no known exploitation of CVE-2018-16873 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16873 and fix it if it is affected.

What it is: CVE-2018-16873 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16873 in the wild and no public exploit code.

Affected packages and fixed versions:
- toolchain (Go): affected all versions; fixed in 1.10.6, 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16873/ (Markdown: https://insights.sbomify.com/CVE-2018-16873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16873
- OSV: https://osv.dev/vulnerability/CVE-2018-16873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16873/
Summaries are generated and may contain mistakes; the official description above is the record.
