# CVE-2018-16886: go.etcd.io/etcd Authentication Bypass

> Attackers can bypass authentication and gain unauthorized access to etcd data if RBAC and client-cert-auth are enabled with matching Common Names.

- **Severity:** Medium 6.8 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-16886, GHSA-h6xx-pmxh-3wgp, GO-2021-0077, RHSA-2019:1352, UBUNTU-CVE-2018-16886

## What is CVE-2018-16886?

CVE-2018-16886 is a medium-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 14 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 are vulnerable to an improper authentication issue when role-based access control (RBAC) is used and client-cert-auth is enabled. If an etcd client server TLS certificate contains a Common Name (CN) which matches a valid RBAC username, a remote attacker may authenticate as that user with any valid (trusted) client certificate in a REST API request to the gRPC-gateway.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-16886?

7 open source packages ship an affected version, including go.etcd.io/etcd/v3 and go.etcd.io/etcd. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.etcd.io/etcd/v3` | Go | From 3.2.0 | 3.2.26 |
| `go.etcd.io/etcd/v3` | Go | From 3.2.0 | 3.2.26 |
| `go.etcd.io/etcd/v3` | Go | From 3.3.0 | 3.3.11 |
| `go.etcd.io/etcd/v3` | Go | From 3.3.0 | 3.3.11 |
| `go.etcd.io/etcd` | Go | All versions | 0.5.0-alpha.5.0.20190108173120-83c051b701d3 |
| `go.etcd.io/etcd` | Go | All versions | 0.5.0-alpha.5.0.20190108173120-83c051b701d3 |
| `go.etcd.io/etcd` | Go | All versions | 0.5.0-alpha.5.0.20190108173120-83c051b701d3 |
| `etcd` | Red Hat:rhel_extras_other:7 | All versions | 0:3.2.26-1.el7 |
| `etcd-debuginfo` | Red Hat:rhel_extras_other:7 | All versions | 0:3.2.26-1.el7 |

Products: Etcd Etcd, Fedoraproject Fedora, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Workstation.

## How do I fix CVE-2018-16886?

Upgrade go.etcd.io/etcd/v3 to a fixed version for your release line: 3.2.26 or 3.3.11.

## Is CVE-2018-16886 being exploited?

There is no known exploitation of CVE-2018-16886 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2021-28235](https://insights.sbomify.com/CVE-2021-28235/): Etcd-io Improper Authentication vulnerability (critical 9.8)
- [CVE-2026-33413](https://insights.sbomify.com/CVE-2026-33413/): etcd: Authorization bypasses in multiple APIs (high 8.8)
- [CVE-2022-34038](https://insights.sbomify.com/CVE-2022-34038/): Denial of service in n/a (high 7.5)
- [CVE-2026-59818](https://insights.sbomify.com/CVE-2026-59818/): etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation (medium 6.5)
- [CVE-2020-15106](https://insights.sbomify.com/CVE-2020-15106/): Improper Input Validation in etcd (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16886 and fix it if it is affected.

What it is: CVE-2018-16886 is a medium-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 14 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-16886 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.etcd.io/etcd/v3 (Go): affected from 3.2.0; fixed in 3.2.26
- go.etcd.io/etcd/v3 (Go): affected from 3.2.0; fixed in 3.2.26
- go.etcd.io/etcd/v3 (Go): affected from 3.3.0; fixed in 3.3.11
- go.etcd.io/etcd/v3 (Go): affected from 3.3.0; fixed in 3.3.11
- go.etcd.io/etcd (Go): affected all versions; fixed in 0.5.0-alpha.5.0.20190108173120-83c051b701d3
- go.etcd.io/etcd (Go): affected all versions; fixed in 0.5.0-alpha.5.0.20190108173120-83c051b701d3
- go.etcd.io/etcd (Go): affected all versions; fixed in 0.5.0-alpha.5.0.20190108173120-83c051b701d3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16886/ (Markdown: https://insights.sbomify.com/CVE-2018-16886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16886
- OSV: https://osv.dev/vulnerability/CVE-2018-16886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16886/
Summaries are generated and may contain mistakes; the official description above is the record.
