{"answers":{"affected":"2 open source packages ship an affected version, including katello. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-16887 in the wild and no public exploit code.","fix":"Upgrade katello to 3.9.0 or later.","what":"CVE-2018-16887 is a medium-severity cross-site scripting vulnerability in Redhat Satellite, published on 13 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-16887 and fix it if it is affected.\n\nWhat it is: CVE-2018-16887 is a medium-severity cross-site scripting vulnerability in Redhat Satellite, published on 13 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-16887 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- katello (RubyGems): affected all versions; fixed in 3.9.0\n- katello (RubyGems): affected all versions; fixed in 3.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16887/ (Markdown: https://insights.sbomify.com/CVE-2018-16887/index.md)","id":"CVE-2018-16887","markdown":"https://insights.sbomify.com/CVE-2018-16887/index.md","name":"CVE-2018-16887","record":{"aliases":["GHSA-mhhc-r88h-2qrm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Red Hat Satellite","requires_auth":"low_privilege","summary":"An attacker with organization editing privileges can execute XSS attacks in Red Hat Satellite, potentially stealing CSRF tokens from higher-privileged users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"satellite","vendor":"redhat"},{"product":"katello","vendor":"theforeman"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting (XSS) flaw was found in the katello component of Satellite. An attacker with privilege to create/edit organizations and locations is able to execute a XSS attacks against other users through the Subscriptions or the Red Hat Repositories wizards. This can possibly lead to malicious code execution and extraction of the anti-CSRF token of higher privileged users. Versions before 3.9.0 are vulnerable.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"katello Cross-site Scripting vulnerability","id":"CVE-2018-16887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:satellite","products":["redhat:satellite"],"type":"xss","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Privilege escalation in systemd","id":"CVE-2018-16888"},"packages":[{"ecosystem":"RubyGems","fixed":["3.9.0"],"introduced":["0"],"last_affected":[],"package":"katello","purl":null,"source":"GHSA-mhhc-r88h-2qrm"},{"ecosystem":"RubyGems","fixed":["3.9.0"],"introduced":["0"],"last_affected":[],"package":"katello","purl":"pkg:gem/katello","source":"GHSA-mhhc-r88h-2qrm"}],"prev":{"headline":"go.etcd.io/etcd Authentication Bypass","id":"CVE-2018-16886"},"products":["katello"],"published":"2019-01-13","related":[{"cvss_score":9.8,"headline":"Puppet-foreman: an authentication bypass vulnerability exists in foreman","id":"CVE-2024-7012","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":9.8,"headline":"Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore","id":"CVE-2024-7923","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":9.1,"headline":"Foreman: excessive permissions for viewer role on preview","id":"CVE-2026-96659","kev_date_added":null,"published":"2026-10-01"},{"cvss_score":9.1,"headline":"Foreman: arbitrary code execution through templates","id":"CVE-2023-0118","kev_date_added":null,"published":"2023-09-20"},{"cvss_score":9.1,"headline":"Hardcoded credentials in n/a","id":"CVE-2008-2369","kev_date_added":null,"published":"2008-08-14"},{"cvss_score":8.8,"headline":"Foreman: foreman: arbitrary code execution via safemode sandbox bypass","id":"CVE-2026-96658","kev_date_added":null,"published":"2026-10-01"},{"cvss_score":8.8,"headline":"Foreman: foreman: privilege escalation to administrator-level access via usergroup role assignment manipulation","id":"CVE-2026-5136","kev_date_added":null,"published":"2026-07-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["The Katello Project"]},"summary":"An attacker with organization editing privileges can execute XSS attacks in Red Hat Satellite, potentially stealing CSRF tokens from higher-privileged users.","url":"https://insights.sbomify.com/CVE-2018-16887/"}