# CVE-2018-16887: katello Cross-site Scripting vulnerability

> An attacker with organization editing privileges can execute XSS attacks in Red Hat Satellite, potentially stealing CSRF tokens from higher-privileged users.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mhhc-r88h-2qrm

## What is CVE-2018-16887?

CVE-2018-16887 is a medium-severity cross-site scripting vulnerability in Redhat Satellite, published on 13 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting (XSS) flaw was found in the katello component of Satellite. An attacker with privilege to create/edit organizations and locations is able to execute a XSS attacks against other users through the Subscriptions or the Red Hat Repositories wizards. This can possibly lead to malicious code execution and extraction of the anti-CSRF token of higher privileged users. Versions before 3.9.0 are vulnerable.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-16887?

2 open source packages ship an affected version, including katello. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katello` | RubyGems | All versions | 3.9.0 |
| `katello` | RubyGems | All versions | 3.9.0 |

Products: Redhat Satellite, Theforeman Katello.

## How do I fix CVE-2018-16887?

Upgrade katello to 3.9.0 or later.

## Is CVE-2018-16887 being exploited?

There is no known exploitation of CVE-2018-16887 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Satellite

- [CVE-2024-7012](https://insights.sbomify.com/CVE-2024-7012/): Puppet-foreman: an authentication bypass vulnerability exists in foreman (critical 9.8)
- [CVE-2024-7923](https://insights.sbomify.com/CVE-2024-7923/): Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore (critical 9.8)
- [CVE-2026-96659](https://insights.sbomify.com/CVE-2026-96659/): Foreman: excessive permissions for viewer role on preview (critical 9.1)
- [CVE-2023-0118](https://insights.sbomify.com/CVE-2023-0118/): Foreman: arbitrary code execution through templates (critical 9.1)
- [CVE-2008-2369](https://insights.sbomify.com/CVE-2008-2369/): Hardcoded credentials in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16887 and fix it if it is affected.

What it is: CVE-2018-16887 is a medium-severity cross-site scripting vulnerability in Redhat Satellite, published on 13 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16887 in the wild and no public exploit code.

Affected packages and fixed versions:
- katello (RubyGems): affected all versions; fixed in 3.9.0
- katello (RubyGems): affected all versions; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16887/ (Markdown: https://insights.sbomify.com/CVE-2018-16887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16887
- OSV: https://osv.dev/vulnerability/CVE-2018-16887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16887/
Summaries are generated and may contain mistakes; the official description above is the record.
