{"answers":{"affected":"2 open source packages ship an affected version, including elefant/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16975 in the wild and no public exploit code.","fix":"Upgrade elefant/cms to 2.0.7 or later.","what":"CVE-2018-16975 is a critical code injection vulnerability in n/a, published on 12 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-16975 and fix it if it is affected.\n\nWhat it is: CVE-2018-16975 is a critical code injection vulnerability in n/a, published on 12 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-16975 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- elefant/cms (Packagist): affected all versions; fixed in 2.0.7\n- elefant/cms (Packagist): affected all versions; fixed in 2.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16975/ (Markdown: https://insights.sbomify.com/CVE-2018-16975/index.md)","id":"CVE-2018-16975","markdown":"https://insights.sbomify.com/CVE-2018-16975/index.md","name":"CVE-2018-16975","record":{"aliases":["GHSA-x2w2-qgv6-8xrm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Elefant CMS","requires_auth":"none","summary":"Attacker can execute arbitrary PHP code via stylesheet name field in Elefant CMS due to insufficient input validation.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"elefant","vendor":"elefantcms"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in /designer/add/stylesheet.php by using a .php extension in the New Stylesheet Name field in conjunction with \u003c?php content, because of insufficient input validation in apps/designer/handlers/csspreview.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elefant CMS PHP Code Execution Vulnerability","id":"CVE-2018-16975","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Race condition in n/a","id":"CVE-2018-16976"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.7"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":null,"source":"GHSA-x2w2-qgv6-8xrm"},{"ecosystem":"Packagist","fixed":["2.0.7"],"introduced":["0"],"last_affected":[],"package":"elefant/cms","purl":"pkg:composer/elefant/cms","source":"GHSA-x2w2-qgv6-8xrm"}],"prev":{"headline":"Elefant CMS Code Execution Vulnerability","id":"CVE-2018-16974"},"products":["n/a"],"published":"2018-09-12","related":[{"cvss_score":9.8,"headline":"Elefant CMS Code Execution Vulnerability","id":"CVE-2018-16974","kev_date_added":null,"published":"2018-09-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attacker can execute arbitrary PHP code via stylesheet name field in Elefant CMS due to insufficient input validation.","url":"https://insights.sbomify.com/CVE-2018-16975/"}