{"answers":{"affected":"2 open source packages ship an affected version, including opencc. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-16982 in the wild and no public exploit code.","fix":"Upgrade opencc to 1.1.2 or later.","what":"CVE-2018-16982 is a medium-severity denial of service vulnerability in n/a, published on 13 Sep 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-16982 and fix it if it is affected.\n\nWhat it is: CVE-2018-16982 is a medium-severity denial of service vulnerability in n/a, published on 13 Sep 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-16982 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opencc (npm): affected all versions; fixed in 1.1.2\n- opencc (npm): affected all versions; fixed in 1.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-16982/ (Markdown: https://insights.sbomify.com/CVE-2018-16982/index.md)","id":"CVE-2018-16982","markdown":"https://insights.sbomify.com/CVE-2018-16982/index.md","name":"CVE-2018-16982","record":{"aliases":["GHSA-9qh2-6fxg-9m4g","MGASA-2018-0443","SUSE-SU-2022:4288-1","SUSE-SU-2024:2102-1","UBUNTU-CVE-2018-16982"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenCC library","requires_auth":"none","summary":"Attackers can cause a denial of service via segmentation fault in OpenCC by providing a crafted .ocd file with out-of-bounds offsets.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"open_chinese_convert","vendor":"byvoid"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Open Chinese Convert (OpenCC) 1.0.5 allows attackers to cause a denial of service (segmentation fault) because BinaryDict::NewFromFile in BinaryDict.cpp may have out-of-bounds keyOffset and valueOffset values via a crafted .ocd file.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","SUSE:Linux Enterprise Module for Desktop Applications 15 SP6","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5","npm","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Chinese Convert subject to Denial of Service via Out-of-bounds Read","id":"CVE-2018-16982","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":8,"n_references":1,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2018-16983"},"packages":[{"ecosystem":"npm","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":null,"source":"GHSA-9qh2-6fxg-9m4g"},{"ecosystem":"npm","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:npm/opencc","source":"GHSA-9qh2-6fxg-9m4g"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","fixed":["1.0.5-150000.5.3.1"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:rpm/suse/opencc\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP5","source":"SUSE-SU-2024:2102-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP6","fixed":["1.0.5-150000.5.3.1"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:rpm/suse/opencc\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP6","source":"SUSE-SU-2024:2102-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["1.0.3-5.3.1"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:rpm/suse/opencc\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2022:4288-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["1.0.3-5.3.1"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:rpm/suse/opencc\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2022:4288-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["1.0.3-5.3.1"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:rpm/suse/opencc\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2022:4288-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["1.0.5-150000.5.3.1"],"introduced":["0"],"last_affected":[],"package":"opencc","purl":"pkg:rpm/opensuse/opencc\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2024:2102-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-16981"},"products":["n/a"],"published":"2018-09-13","related":[{"cvss_score":4.8,"headline":"BYVoid OpenCC MaxMatchSegmentation.cpp MaxMatchSegmentation heap-based overflow","id":"CVE-2025-15536","kev_date_added":null,"published":"2026-01-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can cause a denial of service via segmentation fault in OpenCC by providing a crafted .ocd file with out-of-bounds offsets.","url":"https://insights.sbomify.com/CVE-2018-16982/"}