# CVE-2018-16982: Open Chinese Convert subject to Denial of Service via Out-of-bounds Read

> Attackers can cause a denial of service via segmentation fault in OpenCC by providing a crafted .ocd file with out-of-bounds offsets.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Sep 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-9qh2-6fxg-9m4g, MGASA-2018-0443, SUSE-SU-2022:4288-1, SUSE-SU-2024:2102-1, UBUNTU-CVE-2018-16982

## What is CVE-2018-16982?

CVE-2018-16982 is a medium-severity denial of service vulnerability in n/a, published on 13 Sep 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Open Chinese Convert (OpenCC) 1.0.5 allows attackers to cause a denial of service (segmentation fault) because BinaryDict::NewFromFile in BinaryDict.cpp may have out-of-bounds keyOffset and valueOffset values via a crafted .ocd file.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2018-16982?

2 open source packages ship an affected version, including opencc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencc` | npm | All versions | 1.1.2 |
| `opencc` | npm | All versions | 1.1.2 |
| `opencc` | SUSE:Linux Enterprise Module for Desktop Applications 15 SP5 | All versions | 1.0.5-150000.5.3.1 |
| `opencc` | SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 1.0.5-150000.5.3.1 |
| `opencc` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.0.3-5.3.1 |
| `opencc` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.0.3-5.3.1 |
| `opencc` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 1.0.3-5.3.1 |
| `opencc` | openSUSE:Leap 15.5 | All versions | 1.0.5-150000.5.3.1 |

Products: Byvoid Open Chinese Convert.

## How do I fix CVE-2018-16982?

Upgrade opencc to 1.1.2 or later.

## Is CVE-2018-16982 being exploited?

There is no known exploitation of CVE-2018-16982 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-15536](https://insights.sbomify.com/CVE-2025-15536/): BYVoid OpenCC MaxMatchSegmentation.cpp MaxMatchSegmentation heap-based overflow (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-16982 and fix it if it is affected.

What it is: CVE-2018-16982 is a medium-severity denial of service vulnerability in n/a, published on 13 Sep 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-16982 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencc (npm): affected all versions; fixed in 1.1.2
- opencc (npm): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-16982/ (Markdown: https://insights.sbomify.com/CVE-2018-16982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-16982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-16982
- OSV: https://osv.dev/vulnerability/CVE-2018-16982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-16982/
Summaries are generated and may contain mistakes; the official description above is the record.
