# CVE-2018-17057: TCPDF vulnerable to attackers triggering deserialization of arbitrary data

> Attackers can execute arbitrary code by triggering unsafe deserialization of arbitrary data via the phar:// wrapper in the TCPDF library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-17057, GHSA-5hw4-m7f3-hhx8, UBUNTU-CVE-2018-17057

## What is CVE-2018-17057?

CVE-2018-17057 is a critical unsafe deserialization vulnerability in Limesurvey Limesurvey, published on 14 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in TCPDF before 6.2.22. Attackers can trigger deserialization of arbitrary data via the phar:// wrapper.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-17057?

8 open source packages ship an affected version, including fooman/tcpdf, la-haute-societe/tcpdf and spoonity/tcpdf. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fooman/tcpdf` | Packagist | All versions | 6.2.22 |
| `fooman/tcpdf` | Packagist | All versions | 6.2.22 |
| `la-haute-societe/tcpdf` | Packagist | All versions | 6.2.22 |
| `la-haute-societe/tcpdf` | Packagist | All versions | 6.2.22 |
| `spoonity/tcpdf` | Packagist | All versions | 6.2.22 |
| `spoonity/tcpdf` | Packagist | All versions | 6.2.22 |
| `tecnickcom/tcpdf` | Packagist | All versions | 6.2.22 |
| `tecnickcom/tcpdf` | Packagist | All versions | 6.2.22 |

Products: Limesurvey Limesurvey, Tecnick Tcpdf.

## How do I fix CVE-2018-17057?

Upgrade fooman/tcpdf to 6.2.22 or later.

## Is CVE-2018-17057 being exploited?

There is no known exploitation of CVE-2018-17057 in the wild and no public exploit code.

Public exploit code:

- LimeSurvey < 3.16 - Remote Code Execution (exploitdb)

## Other vulnerabilities in Limesurvey Limesurvey

- [CVE-2025-56422](https://insights.sbomify.com/CVE-2025-56422/): Deserialization in n/a (critical 9.8)
- [CVE-2022-48008](https://insights.sbomify.com/CVE-2022-48008/): File upload in n/a (critical 9.8)
- [CVE-2019-25019](https://insights.sbomify.com/CVE-2019-25019/): SQL injection in n/a (critical 9.8)
- [CVE-2020-11455](https://insights.sbomify.com/CVE-2020-11455/): Path traversal in n/a (critical 9.8)
- [CVE-2019-16184](https://insights.sbomify.com/CVE-2019-16184/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17057 and fix it if it is affected.

What it is: CVE-2018-17057 is a critical unsafe deserialization vulnerability in Limesurvey Limesurvey, published on 14 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17057 in the wild and no public exploit code.

Affected packages and fixed versions:
- fooman/tcpdf (Packagist): affected all versions; fixed in 6.2.22
- fooman/tcpdf (Packagist): affected all versions; fixed in 6.2.22
- la-haute-societe/tcpdf (Packagist): affected all versions; fixed in 6.2.22
- la-haute-societe/tcpdf (Packagist): affected all versions; fixed in 6.2.22
- spoonity/tcpdf (Packagist): affected all versions; fixed in 6.2.22
- spoonity/tcpdf (Packagist): affected all versions; fixed in 6.2.22
- tecnickcom/tcpdf (Packagist): affected all versions; fixed in 6.2.22
- tecnickcom/tcpdf (Packagist): affected all versions; fixed in 6.2.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17057/ (Markdown: https://insights.sbomify.com/CVE-2018-17057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17057
- OSV: https://osv.dev/vulnerability/CVE-2018-17057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17057/
Summaries are generated and may contain mistakes; the official description above is the record.
