{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-17076 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-17076 is a high-severity denial of service vulnerability in n/a, published on 16 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-17076 and fix it if it is affected.\n\nWhat it is: CVE-2018-17076 is a high-severity denial of service vulnerability in n/a, published on 16 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-17076 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-17076/ (Markdown: https://insights.sbomify.com/CVE-2018-17076/index.md)","id":"CVE-2018-17076","markdown":"https://insights.sbomify.com/CVE-2018-17076/index.md","name":"CVE-2018-17076","record":{"aliases":["DEBIAN-CVE-2018-17076","GHSA-gw2g-5r47-23jh","UBUNTU-CVE-2018-17076","openSUSE-SU-2024:13313-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GPP library","requires_auth":"none","summary":"A crafted file causes GPP to exhaust stack memory, leading to a segmentation fault and denial of service.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"general-purpose_preprocessor","vendor":"logological"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"GPP through 2.25 will try to use more memory space than is available on the stack, leading to a segmentation fault or possibly unspecified other impact via a crafted file.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-17076","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":1,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-17077"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.28-1.1"],"introduced":["0"],"last_affected":[],"package":"gpp","purl":"pkg:rpm/opensuse/gpp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13313-1"}],"prev":{"headline":"golang.org/x/net/html NULL Pointer Dereference vulnerability","id":"CVE-2018-17075"},"products":["n/a"],"published":"2018-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A crafted file causes GPP to exhaust stack memory, leading to a segmentation fault and denial of service.","url":"https://insights.sbomify.com/CVE-2018-17076/"}