CVE-2018-17107 tgstation-server cached user logins in legacy server
Cached active logins allow attackers to bypass authentication and access the Tgstation server with any credentials.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-17107?
CVE-2018-17107 is a critical authentication bypass vulnerability in n/a, published on 24 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Tgstation tgstation-server 3.2.4.0 through 3.2.1.0 (fixed in 3.2.5.0), active logins would be cached, allowing subsequent logins to succeed with any username or password.
Which versions are affected by CVE-2018-17107?
2 open source packages ship an affected version, including TGServiceInterface. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
TGServiceInterface NuGet | From 3.2.1.0 | 3.2.5.0 |
TGServiceInterface NuGet | From 3.2.1.0 | 3.2.5.0 |
Products include Tgstation13 Tgstation-Server.
How do I fix CVE-2018-17107?
Upgrade TGServiceInterface to 3.2.5.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2018-17107 being exploited?
There is no known exploitation of CVE-2018-17107 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2025-21611 tgstation-server's role authorization incorrectly OR'd with user's enabled status
- CVE-2024-41799 tgstation-server's DreamMaker environment files outside the deployment directory can be compiled and ran by insufficiently permissioned users
- CVE-2023-32687 Insufficiently Protected ChatBot Credentials in tgstation-server
- CVE-2020-16136 Path traversal in n/a
- CVE-2023-33198 Incorrectly Specified Chat Message Destinations in tgstation-server and DreamMaker API
Sources
Also known as GHSA-42r6-p4px-qvv6.