# CVE-2018-17107: tgstation-server cached user logins in legacy server

> Cached active logins allow attackers to bypass authentication and access the Tgstation server with any credentials.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-42r6-p4px-qvv6

## What is CVE-2018-17107?

CVE-2018-17107 is a critical authentication bypass vulnerability in n/a, published on 24 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Tgstation tgstation-server 3.2.4.0 through 3.2.1.0 (fixed in 3.2.5.0), active logins would be cached, allowing subsequent logins to succeed with any username or password.

## Which versions are affected by CVE-2018-17107?

2 open source packages ship an affected version, including TGServiceInterface. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `TGServiceInterface` | NuGet | From 3.2.1.0 | 3.2.5.0 |
| `TGServiceInterface` | NuGet | From 3.2.1.0 | 3.2.5.0 |

Products: Tgstation13 Tgstation-Server.

## How do I fix CVE-2018-17107?

Upgrade TGServiceInterface to 3.2.5.0 or later.

## Is CVE-2018-17107 being exploited?

There is no known exploitation of CVE-2018-17107 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-21611](https://insights.sbomify.com/CVE-2025-21611/): tgstation-server's role authorization incorrectly OR'd with user's enabled status (high 8.8)
- [CVE-2024-41799](https://insights.sbomify.com/CVE-2024-41799/): tgstation-server's DreamMaker environment files outside the deployment directory can be compiled and ran by insufficiently permissioned users (high 8.4)
- [CVE-2023-32687](https://insights.sbomify.com/CVE-2023-32687/): Insufficiently Protected ChatBot Credentials in tgstation-server (high 7.7)
- [CVE-2020-16136](https://insights.sbomify.com/CVE-2020-16136/): Path traversal in n/a (high 7.7)
- [CVE-2023-33198](https://insights.sbomify.com/CVE-2023-33198/): Incorrectly Specified Chat Message Destinations in tgstation-server and DreamMaker API (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17107 and fix it if it is affected.

What it is: CVE-2018-17107 is a critical authentication bypass vulnerability in n/a, published on 24 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17107 in the wild and no public exploit code.

Affected packages and fixed versions:
- TGServiceInterface (NuGet): affected from 3.2.1.0; fixed in 3.2.5.0
- TGServiceInterface (NuGet): affected from 3.2.1.0; fixed in 3.2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17107/ (Markdown: https://insights.sbomify.com/CVE-2018-17107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17107
- OSV: https://osv.dev/vulnerability/CVE-2018-17107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17107/
Summaries are generated and may contain mistakes; the official description above is the record.
