{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-17144 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-17144 is a high-severity denial of service vulnerability in Bitcoin Bitcoin Core, published on 19 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-17144 and fix it if it is affected.\n\nWhat it is: CVE-2018-17144 is a high-severity denial of service vulnerability in Bitcoin Bitcoin Core, published on 19 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-17144 in the wild and no public exploit code.\n\nAffected product: Bitcoin Bitcoin Core. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-17144/ (Markdown: https://insights.sbomify.com/CVE-2018-17144/index.md)","id":"CVE-2018-17144","markdown":"https://insights.sbomify.com/CVE-2018-17144/index.md","name":"CVE-2018-17144","record":{"aliases":["DEBIAN-CVE-2018-17144","GHSA-35hw-99vw-mgp5","MGASA-2018-0415","openSUSE-SU-2024:0052-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Bitcoin Core client","requires_auth":"none","summary":"Remote attackers can crash Bitcoin Core or Bitcoin Knots applications by sending duplicate inputs, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bitcoin_core","vendor":"bitcoin"},{"product":"bitcoin_knots","vendor":"bitcoinknots"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Bitcoin Core 0.14.x before 0.14.3, 0.15.x before 0.15.2, and 0.16.x before 0.16.3 and Bitcoin Knots 0.14.x through 0.16.x before 0.16.3 allow a remote denial of service (application crash) exploitable by miners via duplicate input. An attacker can make bitcoind or Bitcoin-Qt crash.","ecosystems":["SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":"2018-10-10","github_poc":2,"max_poc_stars":8,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-10-31T09:07:35Z","kind":"github_poc","ref":"https://github.com/hikame/CVE-2018-17144_POC","stars":8,"title":"Put the *.py files to test/functional folder of bitcoin sourcecode (commit: 4901c00792c1dabae4bb01e6373c9b1ed9ef3008)"},{"date":"2018-10-10T19:44:09Z","kind":"github_poc","ref":"https://github.com/iioch/ban-exploitable-bitcoin-nodes","stars":2,"title":"Ban all denial-of-service vulnerability exploitable nodes from your node CVE-2018-17144  "}],"tier":"poc_unverified"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-17144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"bitcoin:bitcoin_core","products":["bitcoin:bitcoin_core"],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":5,"next":{"headline":"Bitcoin Inventory Out-of-Memory Denial-of-Service Attack (CVE-2018-17145)","id":"CVE-2018-17145"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["26.0-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"bitcoin","purl":"pkg:rpm/suse/bitcoin\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0052-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["26.0-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"bitcoin","purl":"pkg:rpm/opensuse/bitcoin\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0052-1"}],"prev":{"headline":"golang.org/x/net/html has Improper Restriction of Operations within the Bounds of a Memory Buffer","id":"CVE-2018-17143"},"products":["n/a"],"published":"2018-09-19","related":[{"cvss_score":7.5,"headline":"Integer overflow in n/a","id":"CVE-2025-46597","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-54604","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-54605","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2019-25220","kev_date_added":null,"published":"2024-11-18"},{"cvss_score":7.5,"headline":"Integer overflow in n/a","id":"CVE-2024-52912","kev_date_added":null,"published":"2024-11-18"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2024-52914","kev_date_added":null,"published":"2024-11-18"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2024-52915","kev_date_added":null,"published":"2024-11-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can crash Bitcoin Core or Bitcoin Knots applications by sending duplicate inputs, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2018-17144/"}