# CVE-2018-17145: Bitcoin Inventory Out-of-Memory Denial-of-Service Attack (CVE-2018-17145)

> Remote attackers can cause denial of service in Bitcoin Core by flooding the network with transaction inv messages containing random hashes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hx3r-jv9q-85jw

## What is CVE-2018-17145?

CVE-2018-17145 is a high-severity denial of service vulnerability in Bitcoin Bitcoin Core, published on 10 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bitcoin Core 0.16.x before 0.16.2 and Bitcoin Knots 0.16.x before 0.16.2 allow remote denial of service via a flood of multiple transaction inv messages with random hashes, aka INVDoS. NOTE: this can also affect other cryptocurrencies, e.g., if they were forked from Bitcoin Core after 2017-11-15.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-17145?

2 open source packages ship an affected version, including bcoin. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bcoin` | npm | All versions | 1.0.2 |
| `bcoin` | npm | All versions | 1.0.2 |

Products: Bcoin Bcoin, Bitcoin Bitcoin Core, Bitcoinknots Bitcoin Knots, Btcd Project Btcd, Decred Dcrd, Litecoin Litecoin, Namecoin Namecoin Core.

## How do I fix CVE-2018-17145?

Upgrade bcoin to 1.0.2 or later.

## Is CVE-2018-17145 being exploited?

There is no known exploitation of CVE-2018-17145 in the wild and no public exploit code.

## Other vulnerabilities in Bitcoin Bitcoin Core

- [CVE-2023-50475](https://insights.sbomify.com/CVE-2023-50475/): bsock uses weak hashing algorithms (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17145 and fix it if it is affected.

What it is: CVE-2018-17145 is a high-severity denial of service vulnerability in Bitcoin Bitcoin Core, published on 10 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17145 in the wild and no public exploit code.

Affected packages and fixed versions:
- bcoin (npm): affected all versions; fixed in 1.0.2
- bcoin (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17145/ (Markdown: https://insights.sbomify.com/CVE-2018-17145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17145
- OSV: https://osv.dev/vulnerability/CVE-2018-17145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17145/
Summaries are generated and may contain mistakes; the official description above is the record.
