CVE-2018-17196 Improper Input Validation in Apache Kafka

High 8.8 Published Updated

Authenticated clients with write permissions can bypass transaction and idempotent ACL validation in Apache Kafka, allowing unauthorized actions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-17196?

CVE-2018-17196 is a high-severity missing authorization vulnerability in Apache Kafka, published on 11 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.

Which versions are affected by CVE-2018-17196?

2 open source packages ship an affected version, including org.apache.kafka:kafka. It affects 1 product.

PackageAffectedFixed in
org.apache.kafka:kafka MavenFrom 0.11.0.02.1.1
org.apache.kafka:kafka MavenFrom 0.11.0.02.1.1

Products include Apache Kafka.

How do I fix CVE-2018-17196?

Upgrade org.apache.kafka:kafka to 2.1.1 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2018-17196 being exploited?

There is no known exploitation of CVE-2018-17196 in the wild and no public exploit code.

Sources

Also known as GHSA-47w3-66wq-cpxg.

Is CVE-2018-17196 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free