# CVE-2018-17196: Improper Input Validation in Apache Kafka

> Authenticated clients with write permissions can bypass transaction and idempotent ACL validation in Apache Kafka, allowing unauthorized actions.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-47w3-66wq-cpxg

## What is CVE-2018-17196?

CVE-2018-17196 is a high-severity missing authorization vulnerability in Apache Kafka, published on 11 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.

## Which versions are affected by CVE-2018-17196?

2 open source packages ship an affected version, including org.apache.kafka:kafka. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kafka:kafka` | Maven | From 0.11.0.0 | 2.1.1 |
| `org.apache.kafka:kafka` | Maven | From 0.11.0.0 | 2.1.1 |

Products: Apache Kafka.

## How do I fix CVE-2018-17196?

Upgrade org.apache.kafka:kafka to 2.1.1 or later.

## Is CVE-2018-17196 being exploited?

There is no known exploitation of CVE-2018-17196 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kafka

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2025-27818](https://insights.sbomify.com/CVE-2025-27818/): Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration (high 8.8)
- [CVE-2026-35554](https://insights.sbomify.com/CVE-2026-35554/): Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition (high 8.7)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)
- [CVE-2025-27819](https://insights.sbomify.com/CVE-2025-27819/): Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17196 and fix it if it is affected.

What it is: CVE-2018-17196 is a high-severity missing authorization vulnerability in Apache Kafka, published on 11 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17196 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kafka:kafka (Maven): affected from 0.11.0.0; fixed in 2.1.1
- org.apache.kafka:kafka (Maven): affected from 0.11.0.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17196/ (Markdown: https://insights.sbomify.com/CVE-2018-17196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17196
- OSV: https://osv.dev/vulnerability/CVE-2018-17196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17196/
Summaries are generated and may contain mistakes; the official description above is the record.
