# CVE-2018-17197: Apache Tika Denial of Service due to Infinite Loop in Tika's SQLite3Parser

> Attackers can cause a denial of service via infinite loop in Apache Tika by providing a crafted SQLite file.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-17197, GHSA-3448-vfvv-xp9g, SUSE-RU-2019:0341-1, SUSE-SU-2019:0341-1, UBUNTU-CVE-2018-17197

## What is CVE-2018-17197?

CVE-2018-17197 is a medium-severity denial of service vulnerability in Apache Tika, published on 24 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A carefully crafted or corrupt sqlite file can cause an infinite loop in Apache Tika's SQLite3Parser in versions 1.8-1.19.1 of Apache Tika.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2018-17197?

2 open source packages ship an affected version, including org.apache.tika:tika-parsers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika-parsers` | Maven | From 1.8 | 1.20 |
| `org.apache.tika:tika-parsers` | Maven | From 1.8 | 1.20 |
| `spacewalk-backend` | SUSE:Manager Proxy 3.2 | All versions | 2.8.57.8-3.10.14 |
| `spacewalk-backend` | SUSE:Manager Proxy 3.2 | All versions | 2.8.57.8-3.10.14 |
| `spacewalk-client-tools` | SUSE:Manager Proxy 3.2 | All versions | 2.8.22.4-3.3.13 |
| `spacewalk-client-tools` | SUSE:Manager Proxy 3.2 | All versions | 2.8.22.4-3.3.13 |
| `spacewalk-proxy-installer` | SUSE:Manager Proxy 3.2 | All versions | 2.8.6.4-3.6.13 |
| `spacewalk-proxy-installer` | SUSE:Manager Proxy 3.2 | All versions | 2.8.6.4-3.6.13 |
| `spacewalk-web` | SUSE:Manager Proxy 3.2 | All versions | 2.8.7.12-3.16.12 |
| `spacewalk-web` | SUSE:Manager Proxy 3.2 | All versions | 2.8.7.12-3.16.12 |
| `branch-network-formula` | SUSE:Manager Server 3.2 | All versions | 0.1.1545038754.c983fa6-3.6.13 |
| `branch-network-formula` | SUSE:Manager Server 3.2 | All versions | 0.1.1545038754.c983fa6-3.6.13 |
| `netty` | SUSE:Manager Server 3.2 | All versions | 4.1.8.Final-2.7.4 |
| `netty` | SUSE:Manager Server 3.2 | All versions | 4.1.8.Final-2.7.4 |
| `py26-compat-salt` | SUSE:Manager Server 3.2 | All versions | 2016.11.10-6.18.14 |
| `py26-compat-salt` | SUSE:Manager Server 3.2 | All versions | 2016.11.10-6.18.14 |
| `python-susemanager-retail` | SUSE:Manager Server 3.2 | All versions | 1.0.1544459934.07229ad-2.9.13 |
| `python-susemanager-retail` | SUSE:Manager Server 3.2 | All versions | 1.0.1544459934.07229ad-2.9.13 |
| `saltboot-formula` | SUSE:Manager Server 3.2 | All versions | 0.1.1546527519.591e925-3.9.13 |
| `saltboot-formula` | SUSE:Manager Server 3.2 | All versions | 0.1.1546527519.591e925-3.9.13 |
| `smdba` | SUSE:Manager Server 3.2 | All versions | 1.6.3-0.3.6.13 |
| `smdba` | SUSE:Manager Server 3.2 | All versions | 1.6.3-0.3.6.13 |
| `spacecmd` | SUSE:Manager Server 3.2 | All versions | 2.8.25.8-3.12.13 |
| `spacecmd` | SUSE:Manager Server 3.2 | All versions | 2.8.25.8-3.12.13 |
| `spacewalk-admin` | SUSE:Manager Server 3.2 | All versions | 2.8.4.3-3.3.13 |
| `spacewalk-admin` | SUSE:Manager Server 3.2 | All versions | 2.8.4.3-3.3.13 |
| `spacewalk-backend` | SUSE:Manager Server 3.2 | All versions | 2.8.57.8-3.10.14 |
| `spacewalk-backend` | SUSE:Manager Server 3.2 | All versions | 2.8.57.8-3.10.14 |
| `spacewalk-branding` | SUSE:Manager Server 3.2 | All versions | 2.8.5.13-3.13.14 |
| `spacewalk-branding` | SUSE:Manager Server 3.2 | All versions | 2.8.5.13-3.13.14 |
| `spacewalk-client-tools` | SUSE:Manager Server 3.2 | All versions | 2.8.22.4-3.3.13 |
| `spacewalk-client-tools` | SUSE:Manager Server 3.2 | All versions | 2.8.22.4-3.3.13 |
| `spacewalk-java` | SUSE:Manager Server 3.2 | All versions | 2.8.78.18-3.21.1 |
| `spacewalk-java` | SUSE:Manager Server 3.2 | All versions | 2.8.78.18-3.21.1 |
| `spacewalk-setup` | SUSE:Manager Server 3.2 | All versions | 2.8.7.6-3.13.13 |
| `spacewalk-setup` | SUSE:Manager Server 3.2 | All versions | 2.8.7.6-3.13.13 |
| `spacewalk-utils` | SUSE:Manager Server 3.2 | All versions | 2.8.18.4-3.6.13 |
| `spacewalk-utils` | SUSE:Manager Server 3.2 | All versions | 2.8.18.4-3.6.13 |
| `spacewalk-web` | SUSE:Manager Server 3.2 | All versions | 2.8.7.12-3.16.12 |
| `spacewalk-web` | SUSE:Manager Server 3.2 | All versions | 2.8.7.12-3.16.12 |

Products: Apache Tika.

## How do I fix CVE-2018-17197?

Upgrade org.apache.tika:tika-parsers to 1.20 or later.

## Is CVE-2018-17197 being exploited?

There is no known exploitation of CVE-2018-17197 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tika

- [CVE-2019-10088](https://insights.sbomify.com/CVE-2019-10088/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 8.8)
- [CVE-2025-66516](https://insights.sbomify.com/CVE-2025-66516/): Apache Tika has XXE vulnerability (high 8.4)
- [CVE-2025-54988](https://insights.sbomify.com/CVE-2025-54988/): Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA (high 8.4)
- [CVE-2018-1335](https://insights.sbomify.com/CVE-2018-1335/): Command injection in org.apache.tika:tika-core (high 8.1)
- [CVE-2019-10094](https://insights.sbomify.com/CVE-2019-10094/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17197 and fix it if it is affected.

What it is: CVE-2018-17197 is a medium-severity denial of service vulnerability in Apache Tika, published on 24 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-17197 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tika:tika-parsers (Maven): affected from 1.8; fixed in 1.20
- org.apache.tika:tika-parsers (Maven): affected from 1.8; fixed in 1.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17197/ (Markdown: https://insights.sbomify.com/CVE-2018-17197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17197
- OSV: https://osv.dev/vulnerability/CVE-2018-17197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17197/
Summaries are generated and may contain mistakes; the official description above is the record.
