# CVE-2018-17247: Improper Restriction of XML External Entity Reference in Elasticsearch

> An XXE vulnerability in Elasticsearch Machine Learning allows attackers to read local files if external network access is permitted in the security policy.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-ccmr-qj26-845g

## What is CVE-2018-17247?

CVE-2018-17247 is a medium-severity vulnerability in Elastic Elasticsearch, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elasticsearch Security versions 6.5.0 and 6.5.1 contain an XXE flaw in Machine Learning's find_file_structure API. If a policy allowing external network access has been added to Elasticsearch's Java Security Manager then an attacker could send a specially crafted request capable of leaking content of local files on the Elasticsearch node. This could allow a user to access information that they should not have access to.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-17247?

2 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 6.5.0 | 6.5.2 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.5.0 | 6.5.2 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2018-17247?

Upgrade org.elasticsearch:elasticsearch to 6.5.2 or later.

## Is CVE-2018-17247 being exploited?

There is no known exploitation of CVE-2018-17247 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17247 and fix it if it is affected.

What it is: CVE-2018-17247 is a medium-severity vulnerability in Elastic Elasticsearch, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17247 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 6.5.0; fixed in 6.5.2
- org.elasticsearch:elasticsearch (Maven): affected from 6.5.0; fixed in 6.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17247/ (Markdown: https://insights.sbomify.com/CVE-2018-17247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17247
- OSV: https://osv.dev/vulnerability/CVE-2018-17247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17247/
Summaries are generated and may contain mistakes; the official description above is the record.
