# CVE-2018-17297: Unzip function in ZipUtil.java in Hutool allows remote attackers to overwrite arbitrary files via directory traversal

> Remote attackers can overwrite arbitrary files via directory traversal in ZIP archives using the Hutool library's unzip function.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-rhq2-2574-78mc

## What is CVE-2018-17297?

CVE-2018-17297 is a high-severity path traversal vulnerability in n/a, published on 21 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The unzip function in ZipUtil.java in Hutool before 4.1.12 allows remote attackers to overwrite arbitrary files via directory traversal sequences in a filename within a ZIP archive.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-17297?

6 open source packages ship an affected version, including cn.hutool:hutool-all, cn.hutool:hutool-core and cn.hutool:hutool-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cn.hutool:hutool-all` | Maven | All versions | 4.1.12 |
| `cn.hutool:hutool-all` | Maven | All versions | 4.1.12 |
| `cn.hutool:hutool-core` | Maven | All versions | 4.1.12 |
| `cn.hutool:hutool-core` | Maven | All versions | 4.1.12 |
| `cn.hutool:hutool-parent` | Maven | All versions | 4.1.12 |
| `cn.hutool:hutool-parent` | Maven | All versions | 4.1.12 |

Products: Hutool Hutool.

## How do I fix CVE-2018-17297?

Upgrade cn.hutool:hutool-all to 4.1.12 or later.

## Is CVE-2018-17297 being exploited?

There is no known exploitation of CVE-2018-17297 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/dromara__hutool_CVE-2018-17297_4-1-1111 (github_poc): https://github.com/shoucheng3/dromara__hutool_CVE-2018-17297_4-1-1111

## Other vulnerabilities in n/a

- [CVE-2023-42276](https://insights.sbomify.com/CVE-2023-42276/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-42277](https://insights.sbomify.com/CVE-2023-42277/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-24162](https://insights.sbomify.com/CVE-2023-24162/): Dromara Hutool Deserialization of Untrusted Data vulnerability (critical 9.8)
- [CVE-2023-24163](https://insights.sbomify.com/CVE-2023-24163/): Dromara hutool vulnerable to SQL Injection (critical 9.8)
- [CVE-2022-22885](https://insights.sbomify.com/CVE-2022-22885/): Improper Certificate Validation in Hutool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17297 and fix it if it is affected.

What it is: CVE-2018-17297 is a high-severity path traversal vulnerability in n/a, published on 21 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17297 in the wild and no public exploit code.

Affected packages and fixed versions:
- cn.hutool:hutool-all (Maven): affected all versions; fixed in 4.1.12
- cn.hutool:hutool-all (Maven): affected all versions; fixed in 4.1.12
- cn.hutool:hutool-core (Maven): affected all versions; fixed in 4.1.12
- cn.hutool:hutool-core (Maven): affected all versions; fixed in 4.1.12
- cn.hutool:hutool-parent (Maven): affected all versions; fixed in 4.1.12
- cn.hutool:hutool-parent (Maven): affected all versions; fixed in 4.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17297/ (Markdown: https://insights.sbomify.com/CVE-2018-17297/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17297
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17297
- OSV: https://osv.dev/vulnerability/CVE-2018-17297

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17297/
Summaries are generated and may contain mistakes; the official description above is the record.
