CVE-2018-17567 Jekyll allows attackers to access arbitrary files by specifying a symlink
Attackers can read arbitrary files by exploiting symlink handling in the Jekyll include configuration, potentially exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-17567?
CVE-2018-17567 is a high-severity path traversal vulnerability in n/a, published on 28 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the "include" key in the "_config.yml" file.
Weakness: CWE-59
Which versions are affected by CVE-2018-17567?
6 open source packages ship an affected version, including jekyll. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
jekyll RubyGems | All versions | 3.6.3 |
jekyll RubyGems | All versions | 3.6.3 |
jekyll RubyGems | From 3.7.0 | 3.7.4 |
jekyll RubyGems | From 3.7.0 | 3.7.4 |
jekyll RubyGems | From 3.8.0 | 3.8.4 |
jekyll RubyGems | From 3.8.0 | 3.8.4 |
Products include Jekyllrb Jekyll.
How do I fix CVE-2018-17567?
Upgrade jekyll to a fixed version for your release line: 3.6.3, 3.7.4 or 3.8.4.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2018-17567 being exploited?
There is no known exploitation of CVE-2018-17567 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2018-17567, DLA-1541-1, GHSA-4xjh-m3qx-49wc, UBUNTU-CVE-2018-17567.