# CVE-2018-17567: Jekyll allows attackers to access arbitrary files by specifying a symlink

> Attackers can read arbitrary files by exploiting symlink handling in the Jekyll include configuration, potentially exposing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-17567, DLA-1541-1, GHSA-4xjh-m3qx-49wc, UBUNTU-CVE-2018-17567

## What is CVE-2018-17567?

CVE-2018-17567 is a high-severity path traversal vulnerability in n/a, published on 28 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the "include" key in the "_config.yml" file.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2018-17567?

6 open source packages ship an affected version, including jekyll. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jekyll` | RubyGems | All versions | 3.6.3 |
| `jekyll` | RubyGems | All versions | 3.6.3 |
| `jekyll` | RubyGems | From 3.7.0 | 3.7.4 |
| `jekyll` | RubyGems | From 3.7.0 | 3.7.4 |
| `jekyll` | RubyGems | From 3.8.0 | 3.8.4 |
| `jekyll` | RubyGems | From 3.8.0 | 3.8.4 |

Products: Jekyllrb Jekyll.

## How do I fix CVE-2018-17567?

Upgrade jekyll to a fixed version for your release line: 3.6.3, 3.7.4 or 3.8.4.

## Is CVE-2018-17567 being exploited?

There is no known exploitation of CVE-2018-17567 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17567 and fix it if it is affected.

What it is: CVE-2018-17567 is a high-severity path traversal vulnerability in n/a, published on 28 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17567 in the wild and no public exploit code.

Affected packages and fixed versions:
- jekyll (RubyGems): affected all versions; fixed in 3.6.3
- jekyll (RubyGems): affected all versions; fixed in 3.6.3
- jekyll (RubyGems): affected from 3.7.0; fixed in 3.7.4
- jekyll (RubyGems): affected from 3.7.0; fixed in 3.7.4
- jekyll (RubyGems): affected from 3.8.0; fixed in 3.8.4
- jekyll (RubyGems): affected from 3.8.0; fixed in 3.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17567/ (Markdown: https://insights.sbomify.com/CVE-2018-17567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17567
- OSV: https://osv.dev/vulnerability/CVE-2018-17567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17567/
Summaries are generated and may contain mistakes; the official description above is the record.
