{"answers":{"affected":"2 open source packages ship an affected version, including yapi-vendor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-17574 in the wild and no public exploit code.","fix":"Upgrade yapi-vendor to 1.3.23 or later.","what":"CVE-2018-17574 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Sep 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-17574 and fix it if it is affected.\n\nWhat it is: CVE-2018-17574 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Sep 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-17574 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yapi-vendor (npm): affected all versions; fixed in 1.3.23\n- yapi-vendor (npm): affected all versions; fixed in 1.3.23\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-17574/ (Markdown: https://insights.sbomify.com/CVE-2018-17574/index.md)","id":"CVE-2018-17574","markdown":"https://insights.sbomify.com/CVE-2018-17574/index.md","name":"CVE-2018-17574","record":{"aliases":["GHSA-5xgh-643p-cp2g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"YApi API management","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into project names, potentially stealing user sessions or executing code in YApi.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yapi","vendor":"ymfe"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in YMFE YApi 1.3.23. There is stored XSS in the name field of a project.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in yapi-vendor","id":"CVE-2018-17574","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"SQL injection in n/a","id":"CVE-2018-17575"},"packages":[{"ecosystem":"npm","fixed":["1.3.23"],"introduced":["0"],"last_affected":[],"package":"yapi-vendor","purl":null,"source":"GHSA-5xgh-643p-cp2g"},{"ecosystem":"npm","fixed":["1.3.23"],"introduced":["0"],"last_affected":[],"package":"yapi-vendor","purl":"pkg:npm/yapi-vendor","source":"GHSA-5xgh-643p-cp2g"}],"prev":{"headline":"File upload in n/a","id":"CVE-2018-17573"},"products":["n/a"],"published":"2018-09-28","related":[{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-70059","kev_date_added":null,"published":"2026-03-09"},{"cvss_score":7.4,"headline":"yapi disables TLS/SSL certificate validation via rejectUnauthorized: false in Axios HTTPS agent","id":"CVE-2025-70058","kev_date_added":null,"published":"2026-02-23"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2025-70060","kev_date_added":null,"published":"2026-03-09"},{"cvss_score":5.4,"headline":"Cross-site Scripting in yapi-vendor","id":"CVE-2021-36686","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":5.1,"headline":"Weak JSON Web Token in yapi-vendor","id":"CVE-2021-27884","kev_date_added":null,"published":"2021-03-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts into project names, potentially stealing user sessions or executing code in YApi.","url":"https://insights.sbomify.com/CVE-2018-17574/"}