# CVE-2018-17574: Cross-site Scripting in yapi-vendor

> Attackers can inject malicious scripts into project names, potentially stealing user sessions or executing code in YApi.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5xgh-643p-cp2g

## What is CVE-2018-17574?

CVE-2018-17574 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Sep 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in YMFE YApi 1.3.23. There is stored XSS in the name field of a project.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-17574?

2 open source packages ship an affected version, including yapi-vendor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yapi-vendor` | npm | All versions | 1.3.23 |
| `yapi-vendor` | npm | All versions | 1.3.23 |

Products: Ymfe Yapi.

## How do I fix CVE-2018-17574?

Upgrade yapi-vendor to 1.3.23 or later.

## Is CVE-2018-17574 being exploited?

There is no known exploitation of CVE-2018-17574 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-70059](https://insights.sbomify.com/CVE-2025-70059/): Denial of service in n/a (high 7.5)
- [CVE-2025-70058](https://insights.sbomify.com/CVE-2025-70058/): yapi disables TLS/SSL certificate validation via rejectUnauthorized: false in Axios HTTPS agent (high 7.4)
- [CVE-2025-70060](https://insights.sbomify.com/CVE-2025-70060/): Cross-site scripting in n/a (medium 5.4)
- [CVE-2021-36686](https://insights.sbomify.com/CVE-2021-36686/): Cross-site Scripting in yapi-vendor (medium 5.4)
- [CVE-2021-27884](https://insights.sbomify.com/CVE-2021-27884/): Weak JSON Web Token in yapi-vendor (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17574 and fix it if it is affected.

What it is: CVE-2018-17574 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Sep 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-17574 in the wild and no public exploit code.

Affected packages and fixed versions:
- yapi-vendor (npm): affected all versions; fixed in 1.3.23
- yapi-vendor (npm): affected all versions; fixed in 1.3.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17574/ (Markdown: https://insights.sbomify.com/CVE-2018-17574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17574
- OSV: https://osv.dev/vulnerability/CVE-2018-17574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17574/
Summaries are generated and may contain mistakes; the official description above is the record.
