{"answers":{"affected":"2 open source packages ship an affected version, including org.grails.plugins:asset-pipeline. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-17605 in the wild and no public exploit code.","fix":"Upgrade org.grails.plugins:asset-pipeline to 3.0.4 or later.","what":"CVE-2018-17605 is a high-severity path traversal vulnerability in n/a, published on 28 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-17605 and fix it if it is affected.\n\nWhat it is: CVE-2018-17605 is a high-severity path traversal vulnerability in n/a, published on 28 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-17605 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.grails.plugins:asset-pipeline (Maven): affected all versions; fixed in 3.0.4\n- org.grails.plugins:asset-pipeline (Maven): affected all versions; fixed in 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-17605/ (Markdown: https://insights.sbomify.com/CVE-2018-17605/index.md)","id":"CVE-2018-17605","markdown":"https://insights.sbomify.com/CVE-2018-17605/index.md","name":"CVE-2018-17605","record":{"aliases":["GHSA-g7wm-22m6-5774"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Grails Asset Pipeline plugin","requires_auth":"none","summary":"Attackers can perform directory traversal in Grails applications using the Asset Pipeline plugin on Jetty, potentially reading arbitrary files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"asset-pipeline","vendor":"asset_pipeline_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"An issue was discovered in the Asset Pipeline plugin before 3.0.4 for Grails. An attacker can perform directory traversal via a crafted request when a servlet-based application is executed in Jetty, because there is a classloader vulnerability that can allow a reverse file traversal route in AssetPipelineFilter.groovy or AssetPipelineFilterCore.groovy.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Asset Pipeline plugin for Grails vulnerable to Path Traversal","id":"CVE-2018-17605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Use after free in n/a","id":"CVE-2018-17607"},"packages":[{"ecosystem":"Maven","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"org.grails.plugins:asset-pipeline","purl":null,"source":"GHSA-g7wm-22m6-5774"},{"ecosystem":"Maven","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"org.grails.plugins:asset-pipeline","purl":"pkg:maven/org.grails.plugins/asset-pipeline","source":"GHSA-g7wm-22m6-5774"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-17596"},"products":["n/a"],"published":"2018-09-28","related":[{"cvss_score":7.5,"headline":"Asset Pipeline Grails Plugin vulnerable to Path Traversal","id":"CVE-2018-1000817","kev_date_added":null,"published":"2018-12-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can perform directory traversal in Grails applications using the Asset Pipeline plugin on Jetty, potentially reading arbitrary files.","url":"https://insights.sbomify.com/CVE-2018-17605/"}