{"answers":{"affected":"2 open source packages ship an affected version, including joomla/framework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-17856 in the wild and no public exploit code.","fix":"Upgrade joomla/framework to 3.8.13 or later.","what":"CVE-2018-17856 is a high-severity code injection vulnerability in Joomla Joomla\\!, published on 9 Oct 2018. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-17856 and fix it if it is affected.\n\nWhat it is: CVE-2018-17856 is a high-severity code injection vulnerability in Joomla Joomla\\!, published on 9 Oct 2018. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-17856 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- joomla/framework (Packagist): affected from 2.5.4; fixed in 3.8.13\n- joomla/framework (Packagist): affected from 2.5.4; fixed in 3.8.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-17856/ (Markdown: https://insights.sbomify.com/CVE-2018-17856/index.md)","id":"CVE-2018-17856","markdown":"https://insights.sbomify.com/CVE-2018-17856/index.md","name":"CVE-2018-17856","record":{"aliases":["GHSA-9m72-pw47-292w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Joomla CMS","requires_auth":"high_privilege","summary":"Administrator-level users can execute arbitrary code in Joomla via the com_joomlaupdate component due to default ACL settings.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"joomla\\!","vendor":"joomla"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An issue was discovered in Joomla! before 3.8.13. com_joomlaupdate allows the execution of arbitrary code. The default ACL config enabled the ability of Administrator-level users to access com_joomlaupdate and trigger code execution.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Joomla RCE Vulnerability","id":"CVE-2018-17856","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"joomla:joomla\\!","products":["joomla:joomla\\!"],"type":"code_injection","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Missing authorization in n/a","id":"CVE-2018-17857"},"packages":[{"ecosystem":"Packagist","fixed":["3.8.13"],"introduced":["2.5.4"],"last_affected":[],"package":"joomla/framework","purl":null,"source":"GHSA-9m72-pw47-292w"},{"ecosystem":"Packagist","fixed":["3.8.13"],"introduced":["2.5.4"],"last_affected":[],"package":"joomla/framework","purl":"pkg:composer/joomla/framework","source":"GHSA-9m72-pw47-292w"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2018-17855"},"products":["n/a"],"published":"2018-10-09","related":[{"cvss_score":9.8,"headline":"PHPMailer Command Injection","id":"CVE-2016-10033","kev_date_added":"2025-07-07","published":"2016-12-30"},{"cvss_score":5.3,"headline":"Joomla! Improper Access Control","id":"CVE-2023-23752","kev_date_added":"2024-01-08","published":"2023-02-16"},{"cvss_score":9.8,"headline":"Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links","id":"CVE-2026-48902","kev_date_added":null,"published":"2026-05-26"},{"cvss_score":9.8,"headline":"[20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package","id":"CVE-2025-25226","kev_date_added":null,"published":"2025-04-08"},{"cvss_score":9.8,"headline":"[20220303] - Core - User row are not bound to a authentication mechanism","id":"CVE-2022-23795","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"[20220305] - Core - Inadequate filtering on the selected Ids","id":"CVE-2022-23797","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"[20220307] - Core - Variable Tampering on JInput $_REQUEST data","id":"CVE-2022-23799","kev_date_added":null,"published":"2022-03-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Administrator-level users can execute arbitrary code in Joomla via the com_joomlaupdate component due to default ACL settings.","url":"https://insights.sbomify.com/CVE-2018-17856/"}