# CVE-2018-17856: Joomla RCE Vulnerability

> Administrator-level users can execute arbitrary code in Joomla via the com_joomlaupdate component due to default ACL settings.

- **Severity:** High 7.2 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9m72-pw47-292w

## What is CVE-2018-17856?

CVE-2018-17856 is a high-severity code injection vulnerability in Joomla Joomla\!, published on 9 Oct 2018. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue was discovered in Joomla! before 3.8.13. com_joomlaupdate allows the execution of arbitrary code. The default ACL config enabled the ability of Administrator-level users to access com_joomlaupdate and trigger code execution.

## Which versions are affected by CVE-2018-17856?

2 open source packages ship an affected version, including joomla/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla/framework` | Packagist | From 2.5.4 | 3.8.13 |
| `joomla/framework` | Packagist | From 2.5.4 | 3.8.13 |

Products: Joomla Joomla\!.

## How do I fix CVE-2018-17856?

Upgrade joomla/framework to 3.8.13 or later.

## Is CVE-2018-17856 being exploited?

There is no known exploitation of CVE-2018-17856 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-17856 and fix it if it is affected.

What it is: CVE-2018-17856 is a high-severity code injection vulnerability in Joomla Joomla\!, published on 9 Oct 2018. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-17856 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla/framework (Packagist): affected from 2.5.4; fixed in 3.8.13
- joomla/framework (Packagist): affected from 2.5.4; fixed in 3.8.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-17856/ (Markdown: https://insights.sbomify.com/CVE-2018-17856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-17856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-17856
- OSV: https://osv.dev/vulnerability/CVE-2018-17856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-17856/
Summaries are generated and may contain mistakes; the official description above is the record.
