CVE-2018-17960 Ckeditor XSS Vulnerability

Medium 6.1 Published Updated

An attacker can execute arbitrary scripts in a victim's browser via a crafted paste in source mode, affecting CKEditor users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-17960?

CVE-2018-17960 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

CKEditor 4.x before 4.11.0 allows user-assisted XSS involving a source-mode paste.

Weakness: CWE-79

Which versions are affected by CVE-2018-17960?

10 open source packages ship an affected version, including typo3/cms, typo3/cms-core and ckeditor. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 8.0.08.7.21
typo3/cms PackagistFrom 8.0.08.7.21
typo3/cms PackagistFrom 9.0.09.5.2
typo3/cms PackagistFrom 9.0.09.5.2
typo3/cms-core PackagistFrom 8.0.08.7.21
typo3/cms-core PackagistFrom 8.0.08.7.21
4 more packages
typo3/cms-core PackagistFrom 9.0.09.5.2
typo3/cms-core PackagistFrom 9.0.09.5.2
ckeditor npmAll versions4.11.0
ckeditor npmAll versions4.11.0

Products include Ckeditor Ckeditor.

How do I fix CVE-2018-17960?

Upgrade typo3/cms to a fixed version for your release line: 8.7.21 or 9.5.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-17960 being exploited?

There is no known exploitation of CVE-2018-17960 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1782262731, DEBIAN-CVE-2018-17960, GHSA-g68x-vvqq-pvw3, UBUNTU-CVE-2018-17960.

Is CVE-2018-17960 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free