# CVE-2018-18206: Denial of Service in Bytom

> An attacker can cause a crash in the Bytom client by sending negative index values during peer discovery.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vc3x-gx6c-g99f, GO-2021-0079

## What is CVE-2018-18206?

CVE-2018-18206 is a high-severity vulnerability in n/a, published on 10 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the client in Bytom before 1.0.6, checkTopicRegister in p2p/discover/net.go does not prevent negative idx values, leading to a crash.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2018-18206?

3 open source packages ship an affected version, including github.com/bytom/bytom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/bytom/bytom` | Go | All versions | 1.0.4-0.20180831054840-1ac3c8ac4f2b |
| `github.com/bytom/bytom` | Go | All versions | 1.0.6 |
| `github.com/bytom/bytom` | Go | All versions | 1.0.6 |

Products: Bytom Bytom.

## How do I fix CVE-2018-18206?

Upgrade github.com/bytom/bytom to a fixed version for your release line: 1.0.4-0.20180831054840-1ac3c8ac4f2b or 1.0.6.

## Is CVE-2018-18206 being exploited?

There is no known exploitation of CVE-2018-18206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18206 and fix it if it is affected.

What it is: CVE-2018-18206 is a high-severity vulnerability in n/a, published on 10 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-18206 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/bytom/bytom (Go): affected all versions; fixed in 1.0.4-0.20180831054840-1ac3c8ac4f2b
- github.com/bytom/bytom (Go): affected all versions; fixed in 1.0.6
- github.com/bytom/bytom (Go): affected all versions; fixed in 1.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18206/ (Markdown: https://insights.sbomify.com/CVE-2018-18206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18206
- OSV: https://osv.dev/vulnerability/CVE-2018-18206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18206/
Summaries are generated and may contain mistakes; the official description above is the record.
