{"answers":{"affected":"4 open source packages ship an affected version, including ro.pippo:pippo-core and ro.pippo:pippo-session. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-18240 in the wild and no public exploit code.","fix":"Upgrade ro.pippo:pippo-core to 1.12.0 or later.","what":"CVE-2018-18240 is a critical unsafe deserialization vulnerability in n/a, published on 11 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-18240 and fix it if it is affected.\n\nWhat it is: CVE-2018-18240 is a critical unsafe deserialization vulnerability in n/a, published on 11 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-18240 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ro.pippo:pippo-core (Maven): affected all versions; fixed in 1.12.0\n- ro.pippo:pippo-core (Maven): affected all versions; fixed in 1.12.0\n- ro.pippo:pippo-session (Maven): affected all versions; fixed in 1.12.0\n- ro.pippo:pippo-session (Maven): affected all versions; fixed in 1.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-18240/ (Markdown: https://insights.sbomify.com/CVE-2018-18240/index.md)","id":"CVE-2018-18240","markdown":"https://insights.sbomify.com/CVE-2018-18240/index.md","name":"CVE-2018-18240","record":{"aliases":["GHSA-h892-x453-86wc"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via unsafe deserialization in the XstreamEngine component of the Pippo framework.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pippo","vendor":"pippo"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Pippo through 1.11.0 allows remote code execution via a command to java.lang.ProcessBuilder because the XstreamEngine component does not use XStream's available protection mechanisms to restrict unmarshalling.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pippo RCE Vulnerability","id":"CVE-2018-18240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2018"},"n_packages":4,"n_references":1,"next":{"headline":"SQL injection in n/a","id":"CVE-2018-18242"},"packages":[{"ecosystem":"Maven","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"ro.pippo:pippo-core","purl":null,"source":"GHSA-h892-x453-86wc"},{"ecosystem":"Maven","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"ro.pippo:pippo-core","purl":"pkg:maven/ro.pippo/pippo-core","source":"GHSA-h892-x453-86wc"},{"ecosystem":"Maven","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"ro.pippo:pippo-session","purl":null,"source":"GHSA-h892-x453-86wc"},{"ecosystem":"Maven","fixed":["1.12.0"],"introduced":["0"],"last_affected":[],"package":"ro.pippo:pippo-session","purl":"pkg:maven/ro.pippo/pippo-session","source":"GHSA-h892-x453-86wc"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2018-18227"},"products":["n/a"],"published":"2018-10-11","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in pippo-core","id":"CVE-2018-20059","kev_date_added":null,"published":"2018-12-11"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in Pippo","id":"CVE-2018-18628","kev_date_added":null,"published":"2018-10-23"},{"cvss_score":7.5,"headline":"XML Entity Expansion in Pippo","id":"CVE-2019-5442","kev_date_added":null,"published":"2019-06-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via unsafe deserialization in the XstreamEngine component of the Pippo framework.","url":"https://insights.sbomify.com/CVE-2018-18240/"}