# CVE-2018-18282: Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page

> Attackers can execute arbitrary scripts in victim browsers via the Next.js error pages, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qw96-mm2g-c8m7

## What is CVE-2018-18282?

CVE-2018-18282 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-18282?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 7.0.0 | 7.0.2 |
| `next` | npm | From 7.0.0 | 7.0.2 |

Products: Zeit Next.js.

## How do I fix CVE-2018-18282?

Upgrade next to 7.0.2 or later.

## Is CVE-2018-18282 being exploited?

There is no known exploitation of CVE-2018-18282 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-6184](https://insights.sbomify.com/CVE-2018-6184/): Directory traversal vulnerability in Next.js (high 7.5)
- [CVE-2017-16877](https://insights.sbomify.com/CVE-2017-16877/): Next.js Directory Traversal Vulnerability (high 7.5)
- [CVE-2020-5284](https://insights.sbomify.com/CVE-2020-5284/): Directory Traversal in Next.js versions below 9.3.2 (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18282 and fix it if it is affected.

What it is: CVE-2018-18282 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-18282 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 7.0.0; fixed in 7.0.2
- next (npm): affected from 7.0.0; fixed in 7.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18282/ (Markdown: https://insights.sbomify.com/CVE-2018-18282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18282
- OSV: https://osv.dev/vulnerability/CVE-2018-18282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18282/
Summaries are generated and may contain mistakes; the official description above is the record.
