{"answers":{"affected":"2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"Yes. Attackers have exploited CVE-2018-18325 in the wild since at least 3 Nov 2021.","fix":"Upgrade DotNetNuke.Core to 9.3.0 or later. US federal agencies must fix it by 3 May 2022.","what":"CVE-2018-18325 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-18325 and fix it if it is affected.\n\nWhat it is: CVE-2018-18325 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2018-18325 in the wild since at least 3 Nov 2021.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.3.0\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-18325/ (Markdown: https://insights.sbomify.com/CVE-2018-18325/index.md)","id":"CVE-2018-18325","markdown":"https://insights.sbomify.com/CVE-2018-18325/index.md","name":"CVE-2018-18325","record":{"aliases":["GHSA-j3g9-6fx5-gjv7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"DNN CMS","requires_auth":"none","summary":"Attackers can exploit weak encryption in DNN to read or manipulate protected input parameters, compromising data integrity and security.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-326","name":"Inadequate Encryption Strength"}],"description":"DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. NOTE: this issue exists because of an incomplete fix for CVE-2018-15811.","ecosystems":["NuGet"],"exploits":{"exploitdb":1,"first_seen":"2017-07-20","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":1,"refs":[{"date":"2017-07-20","kind":"metasploit","ref":"exploit/windows/http/dnn_cookie_deserialization_rce","stars":null,"title":"DotNetNuke Cookie Deserialization Remote Code Excecution"},{"date":"2020-04-16","kind":"exploitdb","ref":"48336","stars":null,"title":"DotNetNuke - Cookie Deserialization Remote Code Execution (Metasploit)"},{"date":null,"kind":"nuclei","ref":"http/cves/2018/CVE-2018-18325.yaml","stars":null,"title":"DotNetNuke 9.2 - 9.2.2 - Weak Encryption \u0026 Cookie Deserialization"}],"tier":"exploited"},"has_fix":true,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","indexable":true,"kev":{"dateAdded":"2021-11-03","dueDate":"2022-05-03","knownRansomwareCampaignUse":"Unknown","product":"DotNetNuke (DNN)","requiredAction":"Apply updates per vendor instructions.","vendorProject":"DotNetNuke (DNN)","vulnerabilityName":"DotNetNuke (DNN) Inadequate Encryption Strength Vulnerability"},"kind":"cve","links":{"ecosystem":"NuGet","product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"weak_cryptography","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Insufficient Entropy in DotNetNuke","id":"CVE-2018-18326"},"packages":[{"ecosystem":"NuGet","fixed":["9.3.0"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-j3g9-6fx5-gjv7"},{"ecosystem":"NuGet","fixed":["9.3.0"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-j3g9-6fx5-gjv7"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-18324"},"products":["n/a"],"published":"2019-07-03","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.8,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","kev_date_added":null,"published":"2017-02-06"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"yes","exploitation":"active","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["n/a"]},"summary":"Attackers can exploit weak encryption in DNN to read or manipulate protected input parameters, compromising data integrity and security.","url":"https://insights.sbomify.com/CVE-2018-18325/"}