# CVE-2018-18325: DotNetNuke (DNN) Inadequate Encryption Strength

> Attackers can exploit weak encryption in DNN to read or manipulate protected input parameters, compromising data integrity and security.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2019
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-j3g9-6fx5-gjv7

## What is CVE-2018-18325?

CVE-2018-18325 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. NOTE: this issue exists because of an incomplete fix for CVE-2018-15811.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2018-18325?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 9.3.0 |
| `DotNetNuke.Core` | NuGet | All versions | 9.3.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2018-18325?

Upgrade DotNetNuke.Core to 9.3.0 or later. US federal agencies must fix it by 3 May 2022.

## Is CVE-2018-18325 being exploited?

Yes. Attackers have exploited CVE-2018-18325 in the wild since at least 3 Nov 2021.

Public exploit code:

- DotNetNuke Cookie Deserialization Remote Code Excecution (metasploit)
- DotNetNuke - Cookie Deserialization Remote Code Execution (Metasploit) (exploitdb)
- DotNetNuke 9.2 - 9.2.2 - Weak Encryption & Cookie Deserialization (nuclei): http/cves/2018/CVE-2018-18325.yaml

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)
- [CVE-2015-2794](https://insights.sbomify.com/CVE-2015-2794/): The installation wizard in DotNetNuke (DNN) allows privilege escalation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18325 and fix it if it is affected.

What it is: CVE-2018-18325 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2018-18325 in the wild since at least 3 Nov 2021.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.3.0
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18325/ (Markdown: https://insights.sbomify.com/CVE-2018-18325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18325
- OSV: https://osv.dev/vulnerability/CVE-2018-18325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18325/
Summaries are generated and may contain mistakes; the official description above is the record.
