# CVE-2018-18326: Insufficient Entropy in DotNetNuke

> Insufficient entropy in encryption key generation allows attackers to bypass security controls in DNN CMS.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xx3h-j3cx-8qfj

## What is CVE-2018-18326?

CVE-2018-18326 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values, resulting in lower than expected entropy. NOTE: this issue exists because of an incomplete fix for CVE-2018-15812.

Weakness: CWE-331 (Insufficient Entropy)

## Which versions are affected by CVE-2018-18326?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 9.3.0 |
| `DotNetNuke.Core` | NuGet | All versions | 9.3.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2018-18326?

Upgrade DotNetNuke.Core to 9.3.0 or later.

## Is CVE-2018-18326 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-18326 exists.

Public exploit code:

- DotNetNuke Cookie Deserialization Remote Code Excecution (metasploit)
- DotNetNuke - Cookie Deserialization Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18326 and fix it if it is affected.

What it is: CVE-2018-18326 is a high-severity vulnerability in Dnnsoftware Dotnetnuke, published on 3 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-18326 exists.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.3.0
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18326/ (Markdown: https://insights.sbomify.com/CVE-2018-18326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18326
- OSV: https://osv.dev/vulnerability/CVE-2018-18326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18326/
Summaries are generated and may contain mistakes; the official description above is the record.
