# CVE-2018-18385: Asciidoctor Infinite Loop vulnerability

> Remote attackers can cause a denial of service via an infinite loop in the Asciidoctor parser due to regex mismatch.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-18385, GHSA-qc9p-mjxm-j2wj, UBUNTU-CVE-2018-18385

## What is CVE-2018-18385?

CVE-2018-18385 is a high-severity denial of service vulnerability in n/a, published on 16 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Asciidoctor in versions < 1.5.8 allows remote attackers to cause a denial of service (infinite loop). The loop was caused by the fact that Parser.next_block was not exhausting all the lines in the reader as the while loop expected it would. This was happening because the regular expression that detects any list was not agreeing with the regular expression that detects a specific list type. So the line kept getting pushed back onto the reader, hence causing the loop.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2018-18385?

2 open source packages ship an affected version, including asciidoctor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asciidoctor` | RubyGems | All versions | 1.5.8 |
| `asciidoctor` | RubyGems | All versions | 1.5.8 |

Products: Asciidoctor Asciidoctor.

## How do I fix CVE-2018-18385?

Upgrade asciidoctor to 1.5.8 or later.

## Is CVE-2018-18385 being exploited?

There is no known exploitation of CVE-2018-18385 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18385 and fix it if it is affected.

What it is: CVE-2018-18385 is a high-severity denial of service vulnerability in n/a, published on 16 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-18385 in the wild and no public exploit code.

Affected packages and fixed versions:
- asciidoctor (RubyGems): affected all versions; fixed in 1.5.8
- asciidoctor (RubyGems): affected all versions; fixed in 1.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18385/ (Markdown: https://insights.sbomify.com/CVE-2018-18385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18385
- OSV: https://osv.dev/vulnerability/CVE-2018-18385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18385/
Summaries are generated and may contain mistakes; the official description above is the record.
