# CVE-2018-18476: mysql-bunuuid-rails vulnerable to SQL injection

> An SQL injection vulnerability in the mysql-binuuid-rails gem allows attackers to manipulate database queries by bypassing default string escaping.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6j63-35hj-vmcg

## What is CVE-2018-18476?

CVE-2018-18476 is a critical SQL injection vulnerability in n/a, published on 24 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mysql-binuuid-rails 1.1.0 and earlier allows SQL Injection because it removes default string escaping for affected database columns.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-18476?

2 open source packages ship an affected version, including mysql-binuuid-rails. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql-binuuid-rails` | RubyGems | All versions | 1.1.1 |
| `mysql-binuuid-rails` | RubyGems | All versions | 1.1.1 |

Products: Nedap Mysql-Binuuid-Rails.

## How do I fix CVE-2018-18476?

Upgrade mysql-binuuid-rails to 1.1.1 or later.

## Is CVE-2018-18476 being exploited?

There is no known exploitation of CVE-2018-18476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18476 and fix it if it is affected.

What it is: CVE-2018-18476 is a critical SQL injection vulnerability in n/a, published on 24 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-18476 in the wild and no public exploit code.

Affected packages and fixed versions:
- mysql-binuuid-rails (RubyGems): affected all versions; fixed in 1.1.1
- mysql-binuuid-rails (RubyGems): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18476/ (Markdown: https://insights.sbomify.com/CVE-2018-18476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18476
- OSV: https://osv.dev/vulnerability/CVE-2018-18476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18476/
Summaries are generated and may contain mistakes; the official description above is the record.
