# CVE-2018-18478: LibreNMS XSS Vulnerability

> Remote attackers can inject arbitrary scripts via the dashboard_name parameter in LibreNMS, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9m82-f3wx-p625

## What is CVE-2018-18478?

CVE-2018-18478 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Persistent Cross-Site Scripting (XSS) issues in LibreNMS before 1.44 allow remote attackers to inject arbitrary web script or HTML via the dashboard_name parameter in the /ajax_form.php resource, related to html/includes/forms/add-dashboard.inc.php, html/includes/forms/delete-dashboard.inc.php, and html/includes/forms/edit-dashboard.inc.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-18478?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 1.44 |
| `librenms/librenms` | Packagist | All versions | 1.44 |

Products: Librenms Librenms.

## How do I fix CVE-2018-18478?

Upgrade librenms/librenms to 1.44 or later.

## Is CVE-2018-18478 being exploited?

There is no known exploitation of CVE-2018-18478 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18478 and fix it if it is affected.

What it is: CVE-2018-18478 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-18478 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 1.44
- librenms/librenms (Packagist): affected all versions; fixed in 1.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18478/ (Markdown: https://insights.sbomify.com/CVE-2018-18478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18478
- OSV: https://osv.dev/vulnerability/CVE-2018-18478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18478/
Summaries are generated and may contain mistakes; the official description above is the record.
