{"answers":{"affected":"6 open source packages ship an affected version, including pg-query and pglast. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-18482 in the wild and no public exploit code.","fix":"Upgrade pg-query to 0.28 or later.","what":"CVE-2018-18482 is a medium-severity denial of service vulnerability in n/a, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-18482 and fix it if it is affected.\n\nWhat it is: CVE-2018-18482 is a medium-severity denial of service vulnerability in n/a, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-18482 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pg-query (PyPI): affected all versions; fixed in 0.28\n- pg-query (PyPI): affected all versions; fixed in 0.28\n- pg-query (PyPI): affected all versions; fixed in 0.28\n- pglast (PyPI): affected all versions; fixed in 0.28\n- pglast (PyPI): affected all versions; fixed in 0.28\n- pglast (PyPI): affected all versions; fixed in 0.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-18482/ (Markdown: https://insights.sbomify.com/CVE-2018-18482/index.md)","id":"CVE-2018-18482","markdown":"https://insights.sbomify.com/CVE-2018-18482/index.md","name":"CVE-2018-18482","record":{"aliases":["GHSA-vm3q-58wm-2r2x","PYSEC-2018-154","PYSEC-2026-895"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL query parser","requires_auth":"none","summary":"A memory leak in the libpg_query library can lead to denial of service, affecting applications using this PostgreSQL query parser.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libpg_query","vendor":"libpg_query_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-772","name":"Missing Release of Resource after Effective Lifetime"}],"description":"An issue was discovered in libpg_query 10-1.0.2. There is a memory leak in pg_query_raw_parse in pg_query_parse.c, which might lead to a denial of service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libpg_query memory leak","id":"CVE-2018-18482","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":6,"n_references":1,"next":{"headline":"Integer overflow in n/a","id":"CVE-2018-18483"},"packages":[{"ecosystem":"PyPI","fixed":["0.28"],"introduced":["0"],"last_affected":[],"package":"pg-query","purl":null,"source":"GHSA-vm3q-58wm-2r2x"},{"ecosystem":"PyPI","fixed":["0.28"],"introduced":["0"],"last_affected":[],"package":"pg-query","purl":"pkg:pypi/pg-query","source":"GHSA-vm3q-58wm-2r2x"},{"ecosystem":"PyPI","fixed":["0.28"],"introduced":["0"],"last_affected":[],"package":"pg-query","purl":"pkg:pypi/pg-query","source":"PYSEC-2018-154"},{"ecosystem":"PyPI","fixed":["0.28"],"introduced":["0"],"last_affected":[],"package":"pglast","purl":null,"source":"GHSA-vm3q-58wm-2r2x"},{"ecosystem":"PyPI","fixed":["0.28"],"introduced":["0"],"last_affected":[],"package":"pglast","purl":"pkg:pypi/pglast","source":"GHSA-vm3q-58wm-2r2x"},{"ecosystem":"PyPI","fixed":["0.28"],"introduced":["0"],"last_affected":[],"package":"pglast","purl":"pkg:pypi/pglast","source":"PYSEC-2026-895"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-18481"},"products":["n/a"],"published":"2018-10-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"A memory leak in the libpg_query library can lead to denial of service, affecting applications using this PostgreSQL query parser.","url":"https://insights.sbomify.com/CVE-2018-18482/"}