# CVE-2018-18482: libpg_query memory leak

> A memory leak in the libpg_query library can lead to denial of service, affecting applications using this PostgreSQL query parser.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vm3q-58wm-2r2x, PYSEC-2018-154, PYSEC-2026-895

## What is CVE-2018-18482?

CVE-2018-18482 is a medium-severity denial of service vulnerability in n/a, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in libpg_query 10-1.0.2. There is a memory leak in pg_query_raw_parse in pg_query_parse.c, which might lead to a denial of service.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2018-18482?

6 open source packages ship an affected version, including pg-query and pglast. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pg-query` | PyPI | All versions | 0.28 |
| `pg-query` | PyPI | All versions | 0.28 |
| `pg-query` | PyPI | All versions | 0.28 |
| `pglast` | PyPI | All versions | 0.28 |
| `pglast` | PyPI | All versions | 0.28 |
| `pglast` | PyPI | All versions | 0.28 |

Products: Libpg Query Project Libpg Query.

## How do I fix CVE-2018-18482?

Upgrade pg-query to 0.28 or later.

## Is CVE-2018-18482 being exploited?

There is no known exploitation of CVE-2018-18482 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18482 and fix it if it is affected.

What it is: CVE-2018-18482 is a medium-severity denial of service vulnerability in n/a, published on 18 Oct 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-18482 in the wild and no public exploit code.

Affected packages and fixed versions:
- pg-query (PyPI): affected all versions; fixed in 0.28
- pg-query (PyPI): affected all versions; fixed in 0.28
- pg-query (PyPI): affected all versions; fixed in 0.28
- pglast (PyPI): affected all versions; fixed in 0.28
- pglast (PyPI): affected all versions; fixed in 0.28
- pglast (PyPI): affected all versions; fixed in 0.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18482/ (Markdown: https://insights.sbomify.com/CVE-2018-18482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18482
- OSV: https://osv.dev/vulnerability/CVE-2018-18482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18482/
Summaries are generated and may contain mistakes; the official description above is the record.
