# CVE-2018-18628: Deserialization of Untrusted Data in Pippo

> Attackers can achieve remote code execution by sending a malicious serialized object in a session cookie to the Pippo web framework.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7fm6-2qw4-g3x3

## What is CVE-2018-18628?

CVE-2018-18628 is a critical unsafe deserialization vulnerability in n/a, published on 23 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Pippo 1.11.0. The function SerializationSessionDataTranscoder.decode() calls ObjectInputStream.readObject() to deserialize a SessionData object without checking the object types. An attacker can create a malicious object, base64 encode it, and place it in the PIPPO_SESSION field of a cookie. Sending this cookie may lead to remote code execution.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-18628?

2 open source packages ship an affected version, including ro.pippo:pippo-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ro.pippo:pippo-core` | Maven | All versions | 1.12.0 |
| `ro.pippo:pippo-core` | Maven | All versions | 1.12.0 |

Products: Pippo Pippo.

## How do I fix CVE-2018-18628?

Upgrade ro.pippo:pippo-core to 1.12.0 or later.

## Is CVE-2018-18628 being exploited?

There is no known exploitation of CVE-2018-18628 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-20059](https://insights.sbomify.com/CVE-2018-20059/): Improper Restriction of XML External Entity Reference in pippo-core (critical 9.8)
- [CVE-2018-18240](https://insights.sbomify.com/CVE-2018-18240/): Pippo RCE Vulnerability (critical 9.8)
- [CVE-2019-5442](https://insights.sbomify.com/CVE-2019-5442/): XML Entity Expansion in Pippo (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18628 and fix it if it is affected.

What it is: CVE-2018-18628 is a critical unsafe deserialization vulnerability in n/a, published on 23 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-18628 in the wild and no public exploit code.

Affected packages and fixed versions:
- ro.pippo:pippo-core (Maven): affected all versions; fixed in 1.12.0
- ro.pippo:pippo-core (Maven): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18628/ (Markdown: https://insights.sbomify.com/CVE-2018-18628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18628
- OSV: https://osv.dev/vulnerability/CVE-2018-18628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18628/
Summaries are generated and may contain mistakes; the official description above is the record.
