# CVE-2018-18854: Uncontrolled Resource Consumption in spray-json

> Remote attackers can cause denial of service via resource consumption in spray-json due to algorithmic complexity during JSON parsing.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-q8xj-8xg3-w432

## What is CVE-2018-18854?

CVE-2018-18854 is a high-severity denial of service vulnerability in n/a, published on 31 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lightbend Spray spray-json through 1.3.4 allows remote attackers to cause a denial of service (resource consumption) because of Algorithmic Complexity during the parsing of many JSON object fields (with keys that have the same hash code).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2018-18854?

6 open source packages ship an affected version, including io.spray:spray-json_2.10, io.spray:spray-json_2.11 and io.spray:spray-json_2.12. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.spray:spray-json_2.10` | Maven | All versions | 1.3.5 |
| `io.spray:spray-json_2.10` | Maven | All versions | 1.3.5 |
| `io.spray:spray-json_2.11` | Maven | All versions | 1.3.5 |
| `io.spray:spray-json_2.11` | Maven | All versions | 1.3.5 |
| `io.spray:spray-json_2.12` | Maven | All versions | 1.3.5 |
| `io.spray:spray-json_2.12` | Maven | All versions | 1.3.5 |

Products: Lightbend Spray-Json.

## How do I fix CVE-2018-18854?

Upgrade io.spray:spray-json_2.10 to 1.3.5 or later.

## Is CVE-2018-18854 being exploited?

There is no known exploitation of CVE-2018-18854 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-18853](https://insights.sbomify.com/CVE-2018-18853/): Uncontrolled Resource Consumption in spray-json when parsing decimal digit fields (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18854 and fix it if it is affected.

What it is: CVE-2018-18854 is a high-severity denial of service vulnerability in n/a, published on 31 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-18854 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.spray:spray-json_2.10 (Maven): affected all versions; fixed in 1.3.5
- io.spray:spray-json_2.10 (Maven): affected all versions; fixed in 1.3.5
- io.spray:spray-json_2.11 (Maven): affected all versions; fixed in 1.3.5
- io.spray:spray-json_2.11 (Maven): affected all versions; fixed in 1.3.5
- io.spray:spray-json_2.12 (Maven): affected all versions; fixed in 1.3.5
- io.spray:spray-json_2.12 (Maven): affected all versions; fixed in 1.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18854/ (Markdown: https://insights.sbomify.com/CVE-2018-18854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18854
- OSV: https://osv.dev/vulnerability/CVE-2018-18854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18854/
Summaries are generated and may contain mistakes; the official description above is the record.
