{"answers":{"affected":"4 open source packages ship an affected version, including py-evm and evm-py. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-18920 in the wild and no public exploit code.","fix":"Upgrade py-evm to 0.2.0a33 or later.","what":"CVE-2018-18920 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-18920 and fix it if it is affected.\n\nWhat it is: CVE-2018-18920 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-18920 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- py-evm (PyPI): affected all versions up to 0.2.0a33; no fix listed\n- py-evm (PyPI): affected all versions up to 0.2.0a33; no fix listed\n- py-evm (PyPI): affected all versions; fixed in 0.2.0a33\n- evm-py (PyPI): affected all versions up to 0.2.0-alpha\\.33; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-18920/ (Markdown: https://insights.sbomify.com/CVE-2018-18920/index.md)","id":"CVE-2018-18920","markdown":"https://insights.sbomify.com/CVE-2018-18920/index.md","name":"CVE-2018-18920","record":{"aliases":["GHSA-vqgp-4jgj-5j64","PYSEC-2018-155","PYSEC-2018-96"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ethereum VM library","requires_auth":"none","summary":"Attackers can cause execution failures in Py-EVM by triggering invalid opcodes, potentially leading to denial of service in Ethereum virtual machine environments.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"py-evm","vendor":"ethereum"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Py-EVM v0.2.0-alpha.33 allows attackers to make a vm.execute_bytecode call that triggers computation._stack.values with '\"stack\": [100, 100, 0]' where b'\\x' was expected, resulting in an execution failure because of an invalid opcode. This is reportedly related to \"smart contracts can be executed indefinitely without gas being paid.\"","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Py-EVM is vulnerable to arbitrary bytecode injection","id":"CVE-2018-18920","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":4,"n_references":4,"next":{"headline":"CSRF in PHP Server Monitor before 3.3.2","id":"CVE-2018-18921"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.2.0-alpha\\.33"],"package":"evm-py","purl":"pkg:pypi/evm-py","source":"PYSEC-2018-155"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.2.0a33"],"package":"py-evm","purl":null,"source":"GHSA-vqgp-4jgj-5j64"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.2.0a33"],"package":"py-evm","purl":"pkg:pypi/py-evm","source":"GHSA-vqgp-4jgj-5j64"},{"ecosystem":"PyPI","fixed":["0.2.0a33"],"introduced":["0"],"last_affected":[],"package":"py-evm","purl":"pkg:pypi/py-evm","source":"PYSEC-2018-96"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-18919"},"products":["n/a"],"published":"2018-11-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause execution failures in Py-EVM by triggering invalid opcodes, potentially leading to denial of service in Ethereum virtual machine environments.","url":"https://insights.sbomify.com/CVE-2018-18920/"}