# CVE-2018-18920: Py-EVM is vulnerable to arbitrary bytecode injection

> Attackers can cause execution failures in Py-EVM by triggering invalid opcodes, potentially leading to denial of service in Ethereum virtual machine environments.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vqgp-4jgj-5j64, PYSEC-2018-155, PYSEC-2018-96

## What is CVE-2018-18920?

CVE-2018-18920 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Py-EVM v0.2.0-alpha.33 allows attackers to make a vm.execute_bytecode call that triggers computation._stack.values with '"stack": [100, 100, 0]' where b'\x' was expected, resulting in an execution failure because of an invalid opcode. This is reportedly related to "smart contracts can be executed indefinitely without gas being paid."

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2018-18920?

4 open source packages ship an affected version, including py-evm and evm-py. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `py-evm` | PyPI | All versions to 0.2.0a33 | None |
| `py-evm` | PyPI | All versions to 0.2.0a33 | None |
| `py-evm` | PyPI | All versions | 0.2.0a33 |
| `evm-py` | PyPI | All versions to 0.2.0-alpha\.33 | None |

Products: Ethereum Py-Evm.

## How do I fix CVE-2018-18920?

Upgrade py-evm to 0.2.0a33 or later.

## Is CVE-2018-18920 being exploited?

There is no known exploitation of CVE-2018-18920 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18920 and fix it if it is affected.

What it is: CVE-2018-18920 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-18920 in the wild and no public exploit code.

Affected packages and fixed versions:
- py-evm (PyPI): affected all versions up to 0.2.0a33; no fix listed
- py-evm (PyPI): affected all versions up to 0.2.0a33; no fix listed
- py-evm (PyPI): affected all versions; fixed in 0.2.0a33
- evm-py (PyPI): affected all versions up to 0.2.0-alpha\.33; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18920/ (Markdown: https://insights.sbomify.com/CVE-2018-18920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18920
- OSV: https://osv.dev/vulnerability/CVE-2018-18920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18920/
Summaries are generated and may contain mistakes; the official description above is the record.
