# CVE-2018-18921: CSRF in PHP Server Monitor before 3.3.2

> Attackers can force authenticated users to perform unintended actions like deleting servers via CSRF in PHP Server Monitor.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w2g4-g8xr-px4x

## What is CVE-2018-18921?

CVE-2018-18921 is a medium-severity vulnerability in n/a, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-18921?

2 open source packages ship an affected version, including phpservermon/phpservermon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpservermon/phpservermon` | Packagist | All versions | 3.3.2 |
| `phpservermon/phpservermon` | Packagist | All versions | 3.3.2 |

Products: Phpservermonitor Php Server Monitor.

## How do I fix CVE-2018-18921?

Upgrade phpservermon/phpservermon to 3.3.2 or later.

## Is CVE-2018-18921 being exploited?

There is no known exploitation of CVE-2018-18921 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-4097](https://insights.sbomify.com/CVE-2021-4097/): CRLF Injection in phpservermon/phpservermon (medium 6.3)
- [CVE-2021-4240](https://insights.sbomify.com/CVE-2021-4240/): phpservermon User.php generatePasswordResetToken predictable algorithm in random number generator (low 2.6)
- [CVE-2021-4241](https://insights.sbomify.com/CVE-2021-4241/): phpservermon User.php setUserLoggedIn predictable algorithm in random number generator (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-18921 and fix it if it is affected.

What it is: CVE-2018-18921 is a medium-severity vulnerability in n/a, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-18921 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpservermon/phpservermon (Packagist): affected all versions; fixed in 3.3.2
- phpservermon/phpservermon (Packagist): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-18921/ (Markdown: https://insights.sbomify.com/CVE-2018-18921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-18921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-18921
- OSV: https://osv.dev/vulnerability/CVE-2018-18921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-18921/
Summaries are generated and may contain mistakes; the official description above is the record.
