# CVE-2018-19148: Caddy allows enumeration of Certificates and Hostnames

> Caddy web server leaks internal hostnames by serving random certificates for invalid requests, allowing attackers to enumerate private domains.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jf2w-mq6r-56v8

## What is CVE-2018-19148?

CVE-2018-19148 is a low-severity vulnerability in n/a, published on 10 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caddy through 0.11.0 sends incorrect certificates for certain invalid requests, making it easier for attackers to enumerate hostnames. Specifically, when unable to match a Host header with a vhost in its configuration, it serves the X.509 certificate for a randomly selected vhost in its configuration. Repeated requests (with a nonexistent hostname in the Host header) permit full enumeration of all certificates on the server. This generally permits an attacker to easily and accurately discover the existence of and relationships among hostnames that weren't meant to be public, though this information could likely have been discovered via other methods with additional effort.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-19148?

2 open source packages ship an affected version, including github.com/caddyserver/caddy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy` | Go | All versions | 0.11.1 |
| `github.com/caddyserver/caddy` | Go | All versions | 0.11.1 |

Products: Caddyserver Caddy.

## How do I fix CVE-2018-19148?

Upgrade github.com/caddyserver/caddy to 0.11.1 or later.

## Is CVE-2018-19148 being exploited?

There is no known exploitation of CVE-2018-19148 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19148 and fix it if it is affected.

What it is: CVE-2018-19148 is a low-severity vulnerability in n/a, published on 10 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19148 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/caddyserver/caddy (Go): affected all versions; fixed in 0.11.1
- github.com/caddyserver/caddy (Go): affected all versions; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19148/ (Markdown: https://insights.sbomify.com/CVE-2018-19148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19148
- OSV: https://osv.dev/vulnerability/CVE-2018-19148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19148/
Summaries are generated and may contain mistakes; the official description above is the record.
