{"answers":{"affected":"2 open source packages ship an affected version, including phpbb/phpbb. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-19274 in the wild and no public exploit code.","fix":"Upgrade phpbb/phpbb to 3.2.4 or later.","what":"CVE-2018-19274 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 17 Nov 2018. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-19274 and fix it if it is affected.\n\nWhat it is: CVE-2018-19274 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 17 Nov 2018. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-19274 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.2.4\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19274/ (Markdown: https://insights.sbomify.com/CVE-2018-19274/index.md)","id":"CVE-2018-19274","markdown":"https://insights.sbomify.com/CVE-2018-19274/index.md","name":"CVE-2018-19274","record":{"aliases":["DLA-1593-1","GHSA-h3mr-q96r-37v4","UBUNTU-CVE-2018-19274"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpBB forum software","requires_auth":"high_privilege","summary":"An attacker with founder admin access can achieve remote code execution via Phar deserialization in phpBB.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"phpbb","vendor":"phpbb"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpBB Remote Code Execution","id":"CVE-2018-19274","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"deserialization","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2018-19275"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.4"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":null,"source":"GHSA-h3mr-q96r-37v4"},{"ecosystem":"Packagist","fixed":["3.2.4"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":"pkg:composer/phpbb/phpbb","source":"GHSA-h3mr-q96r-37v4"}],"prev":{"headline":"Centreon SQL Injection","id":"CVE-2018-19271"},"products":["n/a"],"published":"2018-11-17","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker with founder admin access can achieve remote code execution via Phar deserialization in phpBB.","url":"https://insights.sbomify.com/CVE-2018-19274/"}