# CVE-2018-19274: phpBB Remote Code Execution

> An attacker with founder admin access can achieve remote code execution via Phar deserialization in phpBB.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DLA-1593-1, GHSA-h3mr-q96r-37v4, UBUNTU-CVE-2018-19274

## What is CVE-2018-19274?

CVE-2018-19274 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 17 Nov 2018. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2018-19274?

2 open source packages ship an affected version, including phpbb/phpbb. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | All versions | 3.2.4 |
| `phpbb/phpbb` | Packagist | All versions | 3.2.4 |

Products: Debian Debian Linux, Phpbb Phpbb.

## How do I fix CVE-2018-19274?

Upgrade phpbb/phpbb to 3.2.4 or later.

## Is CVE-2018-19274 being exploited?

There is no known exploitation of CVE-2018-19274 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19274 and fix it if it is affected.

What it is: CVE-2018-19274 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 17 Nov 2018. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19274 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.2.4
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19274/ (Markdown: https://insights.sbomify.com/CVE-2018-19274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19274
- OSV: https://osv.dev/vulnerability/CVE-2018-19274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19274/
Summaries are generated and may contain mistakes; the official description above is the record.
