{"answers":{"affected":"4 open source packages ship an affected version, including phpoffice/phpexcel and phpoffice/phpspreadsheet. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-19277 in the wild and no public exploit code.","fix":"Upgrade phpoffice/phpexcel to 1.8.2 or later.","what":"CVE-2018-19277 is a high-severity vulnerability in n/a, published on 14 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-19277 and fix it if it is affected.\n\nWhat it is: CVE-2018-19277 is a high-severity vulnerability in n/a, published on 14 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-19277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpoffice/phpexcel (Packagist): affected all versions; fixed in 1.8.2\n- phpoffice/phpexcel (Packagist): affected all versions; fixed in 1.8.2\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.5.1\n- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19277/ (Markdown: https://insights.sbomify.com/CVE-2018-19277/index.md)","id":"CVE-2018-19277","markdown":"https://insights.sbomify.com/CVE-2018-19277/index.md","name":"CVE-2018-19277","record":{"aliases":["GHSA-xcrg-29h7-h4cj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP spreadsheet library","requires_auth":"none","summary":"Attackers can bypass XXE protections in PhpSpreadsheet by using UTF-7 encoding in .xlsx files, potentially leading to data exposure.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpspreadsheet","vendor":"phpoffice"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-91","name":"XML Injection"}],"description":"securityScan() in PHPOffice PhpSpreadsheet through 1.5.0 allows a bypass of protection mechanisms for XXE via UTF-7 encoding in a .xlsx file","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2018-11-30","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-11-30","kind":"exploitdb","ref":"46050","stars":null,"title":"PhpSpreadsheet \u003c 1.5.0 - XML External Entity (XXE)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"XXE in PHPSpreadsheet due to encoding issue","id":"CVE-2018-19277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2018"},"n_packages":4,"n_references":4,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-19278"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpexcel","purl":null,"source":"GHSA-xcrg-29h7-h4cj"},{"ecosystem":"Packagist","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpexcel","purl":"pkg:composer/phpoffice/phpexcel","source":"GHSA-xcrg-29h7-h4cj"},{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":null,"source":"GHSA-xcrg-29h7-h4cj"},{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"phpoffice/phpspreadsheet","purl":"pkg:composer/phpoffice/phpspreadsheet","source":"GHSA-xcrg-29h7-h4cj"}],"prev":{"headline":"Deserialization in n/a","id":"CVE-2018-19276"},"products":["n/a"],"published":"2018-11-14","related":[{"cvss_score":9.2,"headline":"PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load","id":"CVE-2026-34084","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":8.8,"headline":"XML External Entity Reference (XXE) in PHPSpreadsheet","id":"CVE-2024-45048","kev_date_added":null,"published":"2024-08-28"},{"cvss_score":8.8,"headline":"XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue","id":"CVE-2019-12331","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":8.3,"headline":"PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class","id":"CVE-2024-56365","kev_date_added":null,"published":"2025-01-03"},{"cvss_score":8.3,"headline":"PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file","id":"CVE-2024-56366","kev_date_added":null,"published":"2025-01-03"},{"cvss_score":8.3,"headline":"PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file","id":"CVE-2024-56408","kev_date_added":null,"published":"2025-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass XXE protections in PhpSpreadsheet by using UTF-7 encoding in .xlsx files, potentially leading to data exposure.","url":"https://insights.sbomify.com/CVE-2018-19277/"}